Uable to connect client over https to a server running on Openssl 3.0.2

I have a problem with some of my clients when trying to connect them to our new CMS server, which we migrated over to an ubuntu 22.04 server. Some of the clients connected immediately while some of them would face the following error:

Method: XmdsBase: Message E = SSL Handshake aborted: ssl=0x76b078b0: Failure in SSL library, usually a protocol error error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure(external/openssl/ssl/s23_clnt.c741 0x66b4ed74:0x00000000

The nginx debug log gives the following error:

SSL_do_handshake() failed (SSL: error:0A0000C1:SSL routines::no shared cipher) while SSL handshaking

Is this a problem with the openssl version? If it is, should I change the configuration of my openssl.cnf somehow? Is there a way to get the client use a compatible cipher? On second thought the client obviously uses the openssl in the system it’s installed on.

I tried to create a proxy for the CMS and XMR servers that could handle the handshake and the client did connect through that, but it got stuck in the splash screen with “missing dependencies” in the log.

Solved this by whipping up an nginx server in docker container, that runs lower Openssl version and works as a reverse proxy for Xibo CMS. The displays became green in CMS and the connection seemed to work properly.

Any chance you can share the steps to get this done. Thank you