Twitter Module Problem

i am having an issue with the twitter module. i have it setup but the only thing that appears is the no tweets message. i tried with different search terms but same result. i turned on debugging mode and had a look at the results but there are no errors.
i am using the latest version 1.7.2 for both cms and client.
any idea where i could look?

If you don’t have any debugging at all, then there might be another issue (there should be a boat load of debugging). Do you have an err_xml file created in your server root?

Hi Dan
no err.xml file. but I have a troubleshoot.txt file

With the server log level changed to “audit” there should be a lot of messages appearing in the logs. If there isn’t, then something is very wrong.

troubleshoot.txt file just returns a CSV formatted extract of the log - if the log isn’t being written, then that file isn’t going to do any good.

Are you certain you have switched on debugging and then recreated the issue as described?

Hi Dan
the logs are being created ok but I do not see the err_xml file. I have searched the entire PC. it is xampp running on a windows 7 PC. I made sure to include hidden and system files in my search.

The err_xml file is only created if logging to database fails - you originally said there wasn’t any logging being recorded.

If you have log messages being recorded - lets see them :smiling_imp:

Hi Dan
in my 1st post I mentioned "i turned on debugging mode and had a look at the results but there are no errors."
the logs are being recorded but there were no obvious errors in the logs.
how can I get the logs to you

Sorry, I misunderstood you.


  • Get to your layout in 1 tab
  • Turn on logging in the other tab
  • Refresh the 1st tab with the layout
  • Download the troubleshoot.txt file
  • Pop it somewhere for us to download (redact any sensitive information)


Hi Dan
the file is at this address

Thanks Austin

OK, great - this is the relevant part of the log:

"2015-03-24 10:35:35","Twitter","searchApi","Calling API with:"
"2015-03-24 10:35:35","Twitter","getTwitterFeed","'{"statuses":[],"search_metadata":{"completed_in":0.019,"max_id":5.8030183203293e+17,"max_id_str":"580301832032931840","query":"%40loretofermoy","refresh_url":"?since_id=580301832032931840&q=%40loretofermoy&result_type=mixed&include_entities=1","count":15,"since_id":0,"since_id_str":"0"}}'"

Try without the @ - it might be that the @ isnt working correctly

Hi Dan
tried it without and still no luck.
I also recreated the region and reapplied the module. does there need to be more than one region for it to work?

Sorry, I wasn’t very clear earlier - the logs show that twitter is returning correctly and everything is working as it should, accept there aren’t any statuses being returned.


If you were to search for something less specific, like “xibo”, you should find that you get results.

I’m not sure why your query doesn’t show anything, as it does on the Twitter homepage (and they should be the same).

Hi Dan
you are correct. the module is returning results from the tweet content and not from the twitter account.
I tested by creating a number of tweets that included a made up word and then set the serach for that word. the module returned the results.
is there any way to fix this or is that just how it is supposed to work.
by the way thanks for all your assistance.

Hi Dan
I think I have figured it out. if the tweets are protected then they will not be returned by the module as they will be visible only to followers.i unprotected them and it works.
Thanks again


Fantastic! That is a good point to note. I’m pleased you have it working.