Twitter images not loading


I upgraded the CMS(3.1.2) and Clients(3 r303.0) on Monday but the Twitter module since then is not showing any images.
We use Xibo in a docker container on Windows with the clients also on Windows machines
It does bring down the text of the tweet but just not the images in the clients or the Design window.
We are using Template 10 with a few overrides but it worked great before the update.
I have Cleared the Cache on the clients also
Is this a known issue ?
Or is there a fix for this issue?


So when testing i have taken down the docker container and run a backup of versions 2.2.2 on the same server and this is working correctly bringing down the Twitter images and Tweets… so i think it might have been an issue with the newer version of the CMS
Is anyone else having this issue ?
Is this a known issue in this version?


Welcome to the community.

We have tested this and don’t seem to have the same issue as you are reporting? Could you try the Verify All button from the Modules page and then do a cache clear in your browser privacy settings to see if that resolves it for you?

If that is not the case then please do come back to us.

Thanks for getting in touch about the issue.
I have Just “Verify All” on the modules page and also cleared my cache in the browser but still getting the same issue.
This is in the Design View layout

This is what runs in the Player

We are using CMS 3.1.2 in a docker container on Windows 10
Players are 3 r303.0
I have reverted back to 2.2.2 CMS and this then works fine after exporting the layout from version 3.1.2 back into 2.2.2


Do you see the Images using no 10 Template without overriding the template?

I have just applied the number 10 template and not overridden the template but still have the same issue


But if I take down the 3.1.2 CMS down in docker and run the 2.2.2 CMS in docker on the same server it works fine

I am not sure what else to suggest as it does not seem to be an issue that I can recreate in our cloud. I have checked with a colleague in the support team who can also confirm all appears to be working as expected.

When you cleared your cache did you do clear "cached images and files’ in the clear browsing data settings opposed to a Shift + F5?

We are using the local server instead of the cloud instance.

I cleared the Cached images and files from the Edge Browser by going into the settings, I didn’t use the shift+ F5

I have also tried the Server on another network that is not managed by our Local authority to rule out any issue with filtering but as it is working for the 2.2.2 on the same server using the same IP it can’t be this…
Is there any way I can send any logs to see if there is anything that might stand out so we can update to the newer version??

Thanks for your Support

Please do pass over any logs :+1:

As you are using Edge, have you tried using the latest chrome browser to see if the same issue occurs?

So logging onto the Admin Dashboard to view the affected layout, I have used both Edge and Chrome but both showing the same issue and also showing the same on the actual displays also.

Yeah, i can grab some of the logs - how do i enable logging for the system? and also do you have a contact to send them over to yourselves

Thanks for all the time and effort

Thanks for giving it a go in Chrome, it was worth a try!

Troubleshooting Log

You can send them in a direct message to me and I will pass over to my colleague who has agreed to take a look for you :+1:

So… i have tried to enable debugging but the page would not load was saying “that there has been an error contact support”
This instance has been updated several times from 1.8 i think…
So i have just taken the docker container down and done a fresh install for 3.1.2 in its own folder
copied in the Config.env file into the folder for the fresh install
started docker with this instance
imported the same layout and enabled Twitter module and put in the API details
Then tried that but only got a black screen

I have been able to run the Diagnostic on this instance though and have got the log files and about to send them over now

Thanks for the support

Just want to confirm you got my PM with the files…

Anything else i can help gather let me know

Thank you

Hi, just to confirm that we have received those and hope to take a look at those for you at some point this week :+1:

HI Mr_Jerry90.

I’ve had a look at your log files and located some SQLSTATE errors that suggest an empty value is trying to be written to the fileSize entry in your database, which is not allowed. To troubleshoot this further please can you run these commands on the machine running your CMS.

docker-compose exec cms-web bash
curl -v "" --output /tmp/test.jpg
ls -al /tmp/test.jpg

Please can you post the response to running this in your command line?

Many Thanks.

PS C:\Xibo-Docker-3.1.3\xibo-docker-3.1.3> docker-compose exec cms-web bash
bash-5.1# curl -v “” --output /tmp/test.jpg
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0* Trying…

GET /media/FVg2K6aX0AABqsR.jpg HTTP/1.1
User-Agent: curl/7.80.0
Accept: /

  • Mark bundle as not supporting multiuse
    < HTTP/1.1 200 OK
    < cache-control: max-age=604800, must-revalidate
    < last-modified: Sat, 18 Jun 2022 05:58:08 GMT
    < timing-allow-origin:,
    < strict-transport-security: max-age=631138519
    < access-control-allow-origin: *
    < access-control-expose-headers: Content-Length
    < X-Content-Type-Options: nosniff
    < Content-Type: image/jpeg
    < Content-Length: 258540
    < Accept-Ranges: bytes
    < Date: Thu, 14 Jul 2022 12:42:22 GMT
    < Connection: keep-alive
    < X-Cache: HIT
    < x-tw-cdn: FT
    < x-served-by: cache-lhr6629-LHR, cache-tw-ZZZ1
    < Server-Timing: x-cache;desc=HIT, x-tw-cdn;desc=FT
    { [780 bytes data]
    100 252k 100 252k 0 0 1175k 0 --:–:-- --:–:-- --:–:-- 1179k
  • Connection #0 to host left intact
    bash-5.1# ls -al /tmp/test/jpg
    ls: /tmp/test/jpg: No such file or directory
    bash-5.1# ls -al /tmp/test.jpg
    -rw-r–r-- 1 root root 258540 Jul 14 12:42 /tmp/test.jpg

Thanks for looking into this for me

After running the commands sent…
i am still getting the image error in the design view

And on the player also getting the same …

Thank you

Thank you for providing the results to that test. Unfortunately we can’t explain why this issue is occurring on your 3.1.2 CMS installation. This issue also has not been replicated on our test setups or reported by another user. The fact that the module is working correctly when you use your 2.2.2 CMS is also unusual. I’m sorry that I do not have a more definitive answer to your issue.

Many Thanks.