Ticker with Dataset: Syntax error or access violation: 1064

Xibo is up and working fine for me however I recently tried to setup a meeting room per the example on the site.

Doing so resulted in only the “No Data returned” setup being displayed. My dataset is as follows;

dtStart = string = column 1
dtEnd = string = column 2
sCompany = string = column 3
sPurpose = string = column 4
sVisitors = string = column 5

In my layout I have added a ticker to my region and set it to my dataset with a duration of 25 seconds. This is the only item in that region. My template for the ticker is as follows;

My Company Welcomes
[dtStart|1] - [dtEnd|2]
for [sPurpose|4]

items per page and row limits are all at their defaults of 0. Ticker order and filter are not set and still the dataset data will not show. The Xibo logs display the following error;

SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'FROM ( SELECT dtStart, dtEnd, sCompany, sPurpose, sVisitors , ’ at line 1

Any ideas?

Additionally I should add that I have also tried

  • filtering the data with the filter field to no avail with

NOW() >= dtStart AND NOW()<=dtEnd

  • setting another region with just a dataset in table layout to verifiy the data is accessible

Could you confirm that it is 1.7.9 CMS please?

Are the dates in correct format and is dtStart < NOW and dtEnd > NOW ?

So it shows your dataset in dataset view module, but not in ticker?

They version is 1.7.8 with a 1.7.9 player on windows. However I did spin up a vm of 1.7.9 and repeated this error with it as well. Unless I’m just missing a setting and that’s why it is failing.

And yes oddly if I use a dataset in the region it shows just fine but if it is a ticker with the same or any dataset it displays nothing.