Synology DSM6+ - Xibo Docker 1.8+ Installation


#21

@Peter is correct. The username and password should be the default.

I am glad to hear that the guide worked well for you. Feedback is always welcomed.

I would add the the note to the end about the default username and password, but I still cannot edit the post anymore. Peter, a little help please.


#22

Hi,

Thank’s :wink:

I confirm that the default identifiers work’s


#23

@cslaughter I’ve edited your post and added a note about default login credentials.


#24

Hello cslaughter!
I have this same problem, I reinstall again the containers and I can’t fix it. I don’t have MariaDB. If it’s permissions problem I don’t know where to carry on looking for.

Thanks!


#25

Hi,

I tried the above installation many times allready on my DS218+, but I never get the mysql database running. It’s keeps restarting all the time. I plan to do a complete reinstall of the DS now. Which Synology packages I need to install minimal to run the above installation?


#26

Does the System account have full access on the folders that needed to be created? I would scrap everything, meaning folders and containers and start fresh. I had to do that many times before I could everything to work correctly. Seems one little mistake renders everything useless.

When you say you don’t have MariaDB, I assume you mean installed under the standard packages of the Synology package manager. Either way it should not matter.

After starting fresh, if you still have an issue, can you please post some logging/error messages?


#27

I believe you only need the stock packages plus docker. As for which could be removed, I do not know.

As for the problem with the DB container restarting over and over, try this

If you are seeing the cms-db container start and stop, I saw that when I did not have the environment variables correct. I would delete your cms-db container, remove everything from the database folder, stop the cms-web container. Then rebuild the cms-db container, then start it. Look at the cmd-db log in docker and see if you see the main database being created. If that looks good and it is staying up, then I would start the cms-web containter. Look at the cms-db log again and see if you see that Xibo configured somethings. If that all looks good, then try to access the cms. If you cannot, please post back with any errors and screen shots of the docker info pages for the cms-db and cms-web containers.

I hope that helps, if not then can you please tell me the exact version of DSM is installed?


#28

Thank you very much for your replys,

I discovered that when I set the web map authorisation to read/write for everyone, everything works fine.But I think that is not very safe configuration. Any suggestions?


#29

When you say “web map”, I am not sure what you are referring to. If you mean the folders that are set and mapped to under web directory, I would try SYSTEM - full access, http (user) - Read, http (Group), and then your username - full access. If for some reason Docker is running under a different user, than that user might need full access on the folders.


#30

Thank you! The SYSTEM - full access works.


#31

:smiley: Nice. Glad to hear you got it working.


#32

Now I have another problem. I try to access the Xibo-cms from another location, but I can’t get it to work. Which ports on my router should be opened to let Xibo-player work from another location, and to access the Xibo-cms.
At this moment I only opened port 443 and direct it to my Synology NAS.


#33

@MichaelJvD

I think you may need to perform this part of the instructions.


#34

Hello cslaughter! This is the key! SYSTEM didn’t have full permissions, now I have the three containers working, thank you so much!

Now I have another problem, i can’t enter to the cms, I try to connect to my domain but the page doesn’t load. I’ve configured the reverse proxy but I don’t know if I’m missing something.

Thanks!


#35

When you say the page doesn’t load, do you get any sort of error message? If so what does it say?


#36

No worries! It’s solved, it was a problem with the password variables, now I can enter but I can’t from outside my pc and I did the reverse proxy step but I don’t know if I have problems with router ports o certs in my Synology or what :frowning: . Thanks!

But now I have another question in mind, if I want to create other CMS in the same DSM, what should I do?

Thank you!


#37

I have everything working now, I’ve had conflict with my router ports. Thank you so much for this awesome guide! Everything working fine!!!


#38

Glad to hear you got it working.

I tried to reply sooner, but the site kept telling me I was offline…


#39

First I would like to thank you cslaughter and alex for getting this running on DSM. It has been great.

I am in the process of wanting to update from 1.83 to 1.89 and I have looked over the documents on “Upgrading with Docker” and making a full backup, and i guess i am just not understanding everything. it says:
“Before starting the upgrade, it’s strongly recommended to take a full backup of your Xibo system. So stop your CMS by issuing the command
docker-compose stop
and then, backup config.env, your docker-compose files, and shared directory and keep them somewhere safe. On a Linux system, you will need to be the root user, or use sudo to make a copy of the shared directory.”

The problem I am having in where is the “config.env” file or the “docker-compose” files

I feel like the reset of the steps to update should be pretty straight forward and I am almost willing to continue without backing up those files.


#40

Open the docker control panel on the Synology and shutdown all the containers.

Go to this directory, if you followed the guide. Backup everything in there. Then as the upgrade notes say, just rename the appropriate container and change the ports. This basically serves as the backup for the docker container should you need to go back. (In that event you would put the container’s name and port settings back, and would be back to where you started on that.)

I hope that answers everything and moves you forward. I myself have not upgraded in a while as we use the API heavily and have not had a need as of yet.