SQLSTATE[22001]: String data, right truncated: 1406 Data too long for column 'title' at row 38

After initiating my Xibo 2.0.1 CMS fresh installation on Windows Server 2012r2 I received this error message and the dump:

#0 C:\PHP_FILES\vendor\robmorgan\phinx\src\Phinx\Db\Adapter\PdoAdapter.php(134): PDO->exec(’\nINSERT INTO s...') #1 C:\PHP_FILES\vendor\robmorgan\phinx\src\Phinx\Db\Adapter\AdapterWrapper.php(171): Phinx\Db\Adapter\PdoAdapter->execute('\nINSERT INTOs…’) #2 C:\PHP_FILES\vendor\robmorgan\phinx\src\Phinx\Migration\AbstractMigration.php(221): Phinx\Db\Adapter\AdapterWrapper->execute(’\nINSERT INTO s...') #3 C:\PHP_FILES\db\migrations\20180130073838_install_migration.php(1131): Phinx\Migration\AbstractMigration->execute('\nINSERT INTOs…’) #4 C:\PHP_FILES\db\migrations\20180130073838_install_migration.php(57): InstallMigration->addData() #5 C:\PHP_FILES\vendor\robmorgan\phinx\src\Phinx\Migration\Manager\Environment.php(127): InstallMigration->up() #6 C:\PHP_FILES\vendor\robmorgan\phinx\src\Phinx\Migration\Manager.php(375): Phinx\Migration\Manager\Environment->executeMigration(Object(InstallMigration), ‘up’) #7 C:\PHP_FILES\vendor\robmorgan\phinx\src\Phinx\Migration\Manager.php(351): Phinx\Migration\Manager->executeMigration(‘production’, Object(InstallMigration), ‘up’) #8 C:\PHP_FILES\vendor\robmorgan\phinx\src\Phinx\Console\Command\Migrate.php(115): Phinx\Migration\Manager->migrate(‘production’, NULL) #9 C:\PHP_FILES\vendor\symfony\console\Command\Command.php(264): Phinx\Console\Command\Migrate->execute(Object(Symfony\Component\Console\Input\ArrayInput), Object(Symfony\Component\Console\Output\StreamOutput)) #10 C:\PHP_FILES\vendor\symfony\console\Application.php(874): Symfony\Component\Console\Command\Command->run(Object(Symfony\Component\Console\Input\ArrayInput), Object(Symfony\Component\Console\Output\StreamOutput)) #11 C:\PHP_FILES\vendor\symfony\console\Application.php(228): Symfony\Component\Console\Application->doRunCommand(Object(Phinx\Console\Command\Migrate), Object(Symfony\Component\Console\Input\ArrayInput), Object(Symfony\Component\Console\Output\StreamOutput)) #12 C:\PHP_FILES\vendor\robmorgan\phinx\src\Phinx\Console\PhinxApplication.php(86): Symfony\Component\Console\Application->doRun(Object(Symfony\Component\Console\Input\ArrayInput), Object(Symfony\Component\Console\Output\StreamOutput)) #13 C:\PHP_FILES\vendor\robmorgan\phinx\src\Phinx\Wrapper\TextWrapper.php(243): Phinx\Console\PhinxApplication->doRun(Object(Symfony\Component\Console\Input\ArrayInput), Object(Symfony\Component\Console\Output\StreamOutput)) #14 C:\PHP_FILES\vendor\robmorgan\phinx\src\Phinx\Wrapper\TextWrapper.php(129): Phinx\Wrapper\TextWrapper->executeRun(Array) #15 C:\PHP_FILES\lib\Helper\Install.php(221): Phinx\Wrapper\TextWrapper->getMigrate() #16 C:\PHP_FILES\lib\routes-install.php(51): Xibo\Helper\Install->Step3(Object(Xibo\Storage\PdoStorageService)) #17 [internal function]: {closure}(‘3’) #18 C:\PHP_FILES\vendor\slim\slim\Slim\Route.php(468): call_user_func_array(Object(Closure), Array) #19 C:\PHP_FILES\vendor\slim\slim\Slim\Slim.php(1355): Slim\Route->dispatch() #20 C:\PHP_FILES\vendor\slim\slim\Slim\Middleware\Flash.php(85): Slim\Slim->call() #21 C:\PHP_FILES\vendor\slim\slim\Slim\Middleware\MethodOverride.php(92): Slim\Middleware\Flash->call() #22 C:\PHP_FILES\vendor\slim\slim\Slim\Slim.php(1300): Slim\Middleware\MethodOverride->call() #23 C:\PHP_FILES\web\install\index.php(134): Slim\Slim->run() #24 {main}

Anyone have a suggestion that could resolve this issue?


What version of MySQL are you using please?

I am using MySQL Version on IIS 8 and PHP 5.6.

The fresh Xibo installation is 2.0.1 (the latest release).


This was what I had in the install_log file:

[2019-04-08 11:43:21] INSTALL.INFO: Installer Step 1 [] {“uid”:“7c2affc”,“method”:“GET”,“route”:"/"}
[2019-04-08 11:46:00] INSTALL.INFO: Installer Step 1 [] {“uid”:“cf96565”,“method”:“GET”,“route”:"/"}
[2019-04-08 11:46:03] INSTALL.INFO: Installer Step 2 [] {“uid”:“af5c1a1”,“method”:“GET”,“route”:"/2"}
[2019-04-08 11:46:59] INSTALL.INFO: Installer Step 3 [] {“uid”:“72aca02”,“method”:“POST”,“route”:"/3"}
[2019-04-08 11:46:59] INSTALL.INFO: Setting unlimited max execution time. [] {“uid”:“72aca02”,“method”:“POST”,“route”:"/3"}

I can replicate this locally with MySQL 5.7 but not with 5.6.

I’ve logged an issue for it here:

The fix that is developed for that may work to resolve this for you. I’m not 100% sure since on 5.6 it works OK for me as it stands.

When will release 2.0.2 be released with this bug fix?

I have the same error.
I use Ubuntu 18.04.1
I think the problem is with mysql version:

mysql Ver 14.14 Distrib 5.7.25

After removing MySQL 5.6 and installing 5.7, I still encountered the same error message.

Since I was not getting much help from the community I decided to dig into this error a bit more in a hope it will isolate the issue. So I started with a fresh PHP installation and found in code in the “migration.php” file that created the tables that were causing me errors.

->addColumn(‘title’, ‘string’, [‘limit’ => 50])

Changed this to read

->addColumn(‘title’, ‘string’, [‘limit’ => 255])


->addColumn(‘installName’, ‘string’, [‘limit’ => 254])

Change it to read

->addColumn(‘installName’, ‘string’, [‘limit’ => 254, ‘default’ => null, ‘null’ => true])

This actually solved the error messages I was getting and completed the installation. However, I am now get a message when its at the login:

Unexpected Error, please contact support.

I am hoping this might help point to the source that folks are having with SQL.


The migration.php file is located under the “db” directory

Can someone confirm if the new version of Xibo has the following columns under “setting”?

After reviewing the bugs in the latest code release 2.0.1 and earlier, I would not recommend that anyone use it on a Windows custom build without first manually applying all the patches to the script files. After I manually fixed all their known bugs, the installation of Xibo was flawless. I wish they just added the code changes to their release and avoid others from experiencing all these issues.

Link to patches that fixed Xibo 2.0.1

I should note that I did not make changes to the docker-compose-MySQL-5.7.yml file since Docker is not used in my installation.

Also, for those migrating from an earlier release of Xibo, you might need to make these changes for the migration to work.