SQL Error when registering DSCS95 on CMS 4

Hello all,

I’m trying to setup 3 new DSCS95 on a freshly installed self-hosted version 4.0.4 CMS.
However, after initally getting the first one to work, I can’t get my 2nd and 3rd one to register.
They give off a HTTP 500 when posting.
Looking at the log I see:
SQLSTATE[22007]: Invalid datetime format: 1366 Incorrect integer value: '' for column xibo_triple-it_nl.display.defaultLayoutId at row 1

The DSCS95 are still running version 3.

I’ve already tried deleting the initial device, to see if it’s value in the DB would somehow be the issue.
But that didn’t help

Anyone have any hints how I can resolve this ?

Kind regards,
Rogier van der Heide

Hey and welcome.

Do you have a default layout configured in your settings:

Hi Dan,

Thanks for the reply. I did have a default layout configured.
However, I believe it was in some limbo state. After deleting all my layouts, and creating new one with 1 of these selected as default layout, it worked again.

Thanks for the reply - we think we got this fixed up in 4.0.5 as well.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.