"Sorry we could not find that page." after upgrading to 3.0.0

To be completed by the original poster:

CMS Version


Installation Method

Custom install

Operating System

debian stable


After upgrading 2.3.10 to 3.0.0, i get a page saying :
" [Logo

Sorry we could not find that page.

Please press the button below to go to your homepage or press back in your browser"

Using debian stable with apache2 and mariadb,

extracting new archive : OK
chown file extracted : OK
create new folder for cms 3.0: OK
chmod/chown new folder : OK
add settings.php from 2.3.10: OK
editing apache2 conf file (with new folder 3.0.0) : OK
using sphinx command to upgrade bdd : OK

the CMS has work fine this morning, but when i try to connect it few hours later, i got the message “Sorry we could not find that page.”

i check chmod/chown, log, and all seems OK

apache log say “GET XXXXXXXX 200” at all request like : - - [02/Jul/2021:16:52:29 +0200] “GET /index.php HTTP/1.1” 200 6913 - - [02/Jul/2021:16:52:29 +0200] “GET /dist/style.bundle.min.js?v=3.0.0&rev= HTTP/1.1” 200 49364 - - [02/Jul/2021:16:52:56 +0200] “GET / HTTP/1.1” 302 1146 - - [02/Jul/2021:16:52:56 +0200] “GET /index.php HTTP/1.1” 200 1206 - - [02/Jul/2021:16:52:57 +0200] “GET /theme/default/img/xibologo.png HTTP/1.1” 200 10366

You run the database migration script?

vendor/bin/phinx migrate -c phinx.php

try this: Upgrade Manual/Custom Install | Xibo Open Source Digital Signage

like i say, yes i already perform that command, and the result was perfectly OK

re-run the command =
Phinx by CakePHP - https://phinx.org. 0.9.2

using config file ./phinx.php
using config parser php
using migration paths

  • /home/site-web/xibo.info.srv.csm/ht-docs/3.0.0/db/migrations
    warning no environment specified, defaulting to: production
    using adapter mysql
    using database xibo

All Done. Took 0.0166s

grep -ri 'Sorry we could not find that page' .

./lib/Middleware/Handlers.php:                        'message' => __('Sorry we could not find that page.')
./locale/default.pot:msgid "Sorry we could not find that page."
./views/not-found.twig:    <p>{% trans "Sorry we could not find that page." %}</p>

the message is generated due to “Middleware/Handlers.php”

specially by this part :

// Handle 404’s
if ($exception instanceof HttpNotFoundException) {
if ($request->isXhr()) {
return $response->withJson([
‘success’ => false,
‘error’ => 404,
‘message’ => __(‘Sorry we could not find that page.’)
], 404);
} else {
return $twig->render($response, ‘not-found.twig’, $viewParams);

someone has a clue with that information ?

after installing xibo on another VM using docker, i reproduct the same error while enable SSL and replacing IP by an internal DNS adresse (was working before that step)

i saw a diffrence while enabling HTTPS : the url was rewrite from https://xibo.internaldomain.xyz/login to https://xibo.internaldomain.xyz/index.php (because i use a copy/paste from custom/apache install to help me configure apache2/docker using SSL)

So i try logging to my old instance with /login and the CMS work fine !!!
i edit my apache2 conf

from : redirectmatch ^/$ https://xibo.internaldomain.xyz/index.php
to : redirectmatch ^/$ https://xibo.internaldomain.xyz/login
and all is OK :slight_smile: :slight_smile: :slight_smile:

thats strange, we update xibo from 1.X version, using the same process/conf and we never get annoying by this index.php URL

problem solved, but is this normal ?

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.