[Solved] Problems when call GetFile() method using SOAP

For example, I want to get this file:

<file type="media" id="10" size="2466" md5="3659986d00e56c929218084aeb991cca" download="xmds" path="xibo-layout-scaler.js"/>

So I call the correlative method via SOAP

GetFile('', '', '10', 'media','', '')

But in GetFileResponse XML, I just see this

<file xsi:type="xsd:base64Binary"/>

So I can’t get file content.
Is there anything wrong?

Updated
Call method GetFile with params like this GetFile(’’, ‘’, ‘10’, ‘media’, 0.0, maxSize)

Where    maxSize - double type
Example maxSize = 123.0

[Problem solved]

XMDS expects you to download files in chunks - so that you can resume etc.

So it would generally expect you to make your first call at offset=0.0, size=512000 bytes, then your next call at offset=512001, size=512000 until you hit the size of the file and complete the download. It may allow you to download files larger than the chunk size in one go by specifying the file size as the chunk size, but keep in mind that has to be loaded in server RAM before it’s sent to via the SOAP service so try and keep your chunk size around 512k where the official clients sit.

1 Like

I’ll notice this. Thank you.