Silly CMS Question

Ive got a really easy question to ask. How do I tell what the address is for my CMS?

Im using a Zotac ZBOX with XAMPP installed as the web server. I have gone through installing it and have access to the localhost/xibo/xibo-cms-1.7.3/ page. I am also using another Zotac ZBox as the Windows Player.

I am now trying to get one of players to communicate with the server and I have no idea what the address would be. I have changed the key to something I would know, but whenever I try to access it, it states that it is unable to connect to the remote server.

I have tried the following:

http://127.0.0.1/
http://127.0.0.1/xibo-server

on the server computer, start menu> cmd
At the console, type ipconfig and hit enter. That is the ip of your server.

It would be better to set up a manual ip windows as if DHCP when you reboot can change the IP.

Localhost is only accessible from the same machine.

2 Likes

Went through those steps, got the result of

Connection-specific DNS Suffix
Link-local IPv6 Address
IPv4 Address
Subnet Mask
Default Gateway

I used the IPv4 Address and got the result of:

Saving with CMS…Please wait… Invalid URI: The formate of the URI could not be determined.

I then added http:// to the front of it and and a / to the end and got:

Status
The request failed with HTTP status 404: Not Found.

Do I need to add a port or something to the end of the address?

@njohnson

Try using http://(IPv4 Address of CMS)/xibo/

Tried that, got the result of

Status
The request failed with HTTP status 404: Not Found.

I used the IPv4 address from the ipconfig command with http:// and put /xibo/ at the end of it.

(http://ipv4address/xibo/)

When I type that exact address into the web browser on the PC Im using as the server, it brings me to the Index of /xibo page.

Additionally, when I type it into the web browser on the PC Im using as a Player Client, it brings me to the same Index of /xibo page.

It’ll be http://ipv4address/xibo/xibo-cms-1.7.3

as that’s the URL you use to log in in your case

I think i am having the same issue.
My xibo is installed to the root of the htdocs in xampp so the address is:
http://localhost:8080/xibo/

When i use my computers ip: http://192.168.1.135/xibo i get a message saying, unable to connect to cms at that address,

Any ideas?

You’re missing your custom port number.

The address would be

http://192.168.1.135:8080/xibo