RSS doesn't work when connecting to https://

I host my own RSS Feed and display this in Xibo.
When using http:// it works fine, but when I edit the URL to https:// in Xibo nothing shows up.

I have read this article “Using Tickers, Forecast, Twitter and other external resources that make use of HTTPS connections” but installing the “ca-certificates” package can’t solve my problem.
I use linux redhat but my certificate is provided by our own CA server and this is not world wide known.

You need to use a valid signed certificate or add your local CA to your operating systems own list of valid CAs so that it’s considered to be valid

I checked the certificate with openssl and it was true that it was considered a self-signed certificate and that it wasn’t valid.
But it’s valid now only Xibo still doesn’t work. Could you maybe tell me where Xibo will be looking for this certificate in RedHat 6.6?

Xibo doesn’t check the certificate. PHP/curl do so it will depend where
they are configured to look for the root certificates

Is it possible that php-curl isn’t installed on my Xibo server? I cannot find this entry in my php.ini and I cannot find this in the Xibo install requirements.

The curl module is a requirement and we check for it at installation/upgrade.

If you go to the report fault page you’ll see it with a tick against it if you have it installed correctly.

I don’t use Redhat (and never have) so I don’t know where they would put their certificate files or how you would go about updating them. A Redhat forum will be more likely to give you the answers you need.

Okay thanks, I think I have done everything possible but it still gives the same error.
I now connect to this RSS feed in http:// as a workaround.

You really need to solve it properly. Other things rely on https validation too so you won’t be able to use the Twitter or Weather integrations without solving the problem.

Yeah I really want to solve it too.
The weather and twitter module work fine, but they use a certificate that is in the curl certification list.
This RSS uses a certificate from our own office CA.

I have put this certificate in the same list but the error keeps coming back.

Someone on a Redhat forum must know where the system keeps it’s list of root CA certificates. Once you find that location, it should be a case of putting a copy of the office root CA certificate in there, and then there’s usually a command to run to rebuild the certificates from those files (at least it’s that way on Ubuntu).

That seems to detail the process using Redhat’s tools. Perhaps try that? Alternatively in the CMS Post-Installation guide there’s the instructions for setting CURL up with a CA root list for Windows machines. Try configuring php to use that file instead, and append your office CA root to that file.

Thanks, I will take a look.