Proxy error 400 when loading twitter feed

Xibo 1.7.7 CMS on a ubuntu machine, connecting to twitter through an authenticated proxy. I’m able to reach twitter from the command line using curl, but the error log shows the following (edited for privacy)

4319 16-06-03 01:12:55 CMS Twitter getToken Error contacting Twitter API: Received HTTP code 400 from proxy after CONNECT
4318 16-06-03 01:12:55 CMS image GetResource Image Request 1506x847 /var/www/library/19.jpg. Thumb:
4317 16-06-03 01:12:55 CMS module Module created with MediaID: 19 LayoutID: 0 and RegionID:
4316 16-06-03 01:12:55 CMS Config isProxyException in . Pos =
4315 16-06-03 01:12:55 CMS module Creating new module with MediaID: 19 LayoutID: 0 and RegionID:
4314 16-06-03 01:12:55 CMS Twitter getToken Bearer Token served from API
4313 16-06-03 01:12:54 CMS Cache has bearer_::random hash::== not present
4312 16-06-03 01:12:54 CMS Twitter getTwitterFeed Querying API for ::search term::

I have the proxy set in /etc/environment and /etc/bash.bashrc, as well as the network settings page in the Xibo CMS. I’ve also tried multiple combinations, as the password contains special characters.

You may need to configure your proxy to allow unauthenticated access to the CMS’s IP address. I’m not aware that Xibo CMS supports an authenticated proxy.

I’ll see if I can do that. I would like to point out that the network panel in the CMS has an option to set the username/password for a network proxy.

Oh right. Apologies.

In that case, it’s probably as you suggest something to do with special characters in the password then. They get run through a sanitizer so it’s likely that.