Problems when installing PHP dependencies for the CMS using docker


#1

I’m currently trying to setup a local version of Xibo’s CMS on my computer. After forking the CMS repository, I ran:

docker run --interactive --tty --volume $PWD:/app --volume ~/.composer:/tmp composer install

Which produced the following errors:

Problem 1
- Installation request for doctrine/inflector v1.3.0 -> satisfiable by doctrine/inflector[v1.3.0].
- doctrine/inflector v1.3.0 requires php ^7.1 -> your PHP version (7.3.3) overridden by “config.platform.php” version (7) does not satisfy that requirement.
Problem 2
- Installation request for mongodb/mongodb 1.4.2 -> satisfiable by mongodb/mongodb[1.4.2].
- mongodb/mongodb 1.4.2 requires ext-mongodb ^1.5.0 -> the requested PHP extension mongodb is missing from your system.
Problem 3
- Installation request for symfony/console v4.2.3 -> satisfiable by symfony/console[v4.2.3].
- symfony/console v4.2.3 requires php ^7.1.3 -> your PHP version (7.3.3) overridden by “config.platform.php” version (7) does not satisfy that requirement.
Problem 4
- Installation request for symfony/contracts v1.0.2 -> satisfiable by symfony/contracts[v1.0.2].
- symfony/contracts v1.0.2 requires php ^7.1.3 -> your PHP version (7.3.3) overridden by “config.platform.php” version (7) does not satisfy that requirement.
Problem 5
- Installation request for symfony/event-dispatcher v3.4.22 -> satisfiable by symfony/event-dispatcher[v3.4.22].
- symfony/event-dispatcher v3.4.22 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.3.3) overridden by “config.platform.php” version (7) does not satisfy that requirement.
Problem 6
- Installation request for symfony/filesystem v3.4.22 -> satisfiable by symfony/filesystem[v3.4.22].
- symfony/filesystem v3.4.22 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.3.3) overridden by “config.platform.php” version (7) does not satisfy that requirement.
Problem 7
- Installation request for symfony/http-foundation v3.4.22 -> satisfiable by symfony/http-foundation[v3.4.22].
- symfony/http-foundation v3.4.22 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.3.3) overridden by “config.platform.php” version (7) does not satisfy that requirement.
Problem 8
- Installation request for symfony/translation v3.4.22 -> satisfiable by symfony/translation[v3.4.22].
- symfony/translation v3.4.22 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.3.3) overridden by “config.platform.php” version (7) does not satisfy that requirement.
Problem 9
- Installation request for symfony/yaml v4.2.3 -> satisfiable by symfony/yaml[v4.2.3].
- symfony/yaml v4.2.3 requires php ^7.1.3 -> your PHP version (7.3.3) overridden by “config.platform.php” version (7) does not satisfy that requirement.
Problem 10
- Installation request for doctrine/annotations v1.6.0 -> satisfiable by doctrine/annotations[v1.6.0].
- doctrine/annotations v1.6.0 requires php ^7.1 -> your PHP version (7.3.3) overridden by “config.platform.php” version (7) does not satisfy that requirement.
Problem 11
- Installation request for myclabs/deep-copy 1.8.1 -> satisfiable by myclabs/deep-copy[1.8.1].
- myclabs/deep-copy 1.8.1 requires php ^7.1 -> your PHP version (7.3.3) overridden by “config.platform.php” version (7) does not satisfy that requirement.
Problem 12
- doctrine/inflector v1.3.0 requires php ^7.1 -> your PHP version (7.3.3) overridden by “config.platform.php” version (7) does not satisfy that requirement.
- illuminate/support v5.2.45 requires doctrine/inflector ~1.0 -> satisfiable by doctrine/inflector[v1.3.0].
- Installation request for illuminate/support v5.2.45 -> satisfiable by illuminate/support[v5.2.45].

To enable extensions, verify that they are enabled in your .ini files:
-
- /usr/local/etc/php/conf.d/date_timezone.ini
- /usr/local/etc/php/conf.d/docker-php-ext-sodium.ini
- /usr/local/etc/php/conf.d/docker-php-ext-zip.ini
- /usr/local/etc/php/conf.d/memory-limit.ini
You can also run php --ini inside terminal to see which files are used by PHP in CLI mode.

Is there something wrong with my local configuration?