Probleme to display a embedded webpage

Hi guys !

Sorry for my poor English. I’m french. Support for xibo in French being very limited, I explain my problem to you.

I would like to embedded this webpage :

In my IE it work well, but in xibo, display stops in the middle of the first upper left picture in the page. I have IE 8 installed on the computer with xibo player, so I already added a browser emulation registry key :

HKLM\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION
XiboClient.exe = (DWORD) 00008000

But the result is the same.

Could anybody try my web page in its xibo to tell me if the problem comes from my xibo or from my web page?

Thank you in advance.


Hi Arno,

I tried to display your webpage with different settings (manual position/best fit/open natively)
And on Windows player it seems fine as in preview layout.
Could you tell me which CMS and player version are you using?

Hi Peter,
Thank you for the test.
I’m using 1.7.3 version for the CMS and same version for player.

In the layout design and in the preview layout, I have a right display too !!
My problem comes from the display, I think.

Well if you also tried other options (like open natively - page is in control of sizing itself) and it is still like that,
then I would suggest updating IE to version 11 and then changing registry entry to XiboClient.exe = (DWORD) 11000
this way you will have similar environment to the one that I have, so that should help.
Please let me know.


Probleme is that the computer I’m using for diplay is an old one. I’m afraid that it is not possible to me to install IE11. :confused: IE 8 is the most recent version accepted by Windows XP.

And if I tried to use the version 7 of IE to remain compatible with the .net Browser control ?

The mechanism’s for scaling that Xibo uses don’t appear to work well on some websites in IE8 (or IE7) and yet work well in IE9+. I appreciate you can’t change that on your older PC.

I recommend you use the “Open Natively” function in Xibo. This means that Xibo doesn’t apply any scaling or positioning and opens the webpage directly in the WebBrowser Control in .NET.

By taking this approach you know that your website is being opened directly in IE8 without any interference from Xibo and can look to adjust the code inside the website to suit IE8 (or better yet IE7).

In our experience its the doctype that causes the page not to fit correctly - that might be a good starting point.


As an alternative you could enable the experimental CEF browser control in the player by ticking the box in the display profile on the CMS. After ticking the box you should wait for your collection interval to ensure the player has the new setting and then restart the player. (alternatively restart the player twice :smile:)

CEF is experimental because we have stability issues on some systems - however it is a much later version of Chromium and should display webpages identically to Chrome.

I tried everything possible. Enable double buffering or not, CEF web browse or not, manual position, Open natively, Best fit. Different scale percentage, background tranparent. Nothing can be done.

As the page blocks on the picture, could it be the type of the image who is involved ? It’s a JPG picture. I’m going to try to change de picture.

With all the realized tests, I observed that what displays on xibo player is a square about 50x50 pixels in which appears my webpage of 1795 x1080. This is why I only see the upper left of the page. Nothing to see with the picture in the webpage.

This square can be seen in the CMS too, when I save the Edit of the WebPage. IE, when I click on Apply, during half a second, I can see this square (yes, in the CMS !!), Then, the web page appears above. What is not made on the display.

Something else, I’m using the option CEF since de biginning. Better than without, in particulary for the size of layers.

Hi all, Hi Dan,

Just a feedback to inform you that today I changed my client computer, with windows 7 installed and IE11. The result is that everythink work well as it can.

Thanks for your contribution.

All the best.


Hi Arno,

I am sorry that you had to change your PC, but we are glad that now everything is working as it should.
Thank you for feedback.