Powerbi webpage load issue

Player Version 2 R257.2

Issue:

I’m trying to show some powerbi dashboards on xibo player for windows, for example this URL: https://app.powerbi.com/view?r=eyJrIjoiYjcxZjg4OWEtYmI0NS00ZTEyLWI5NTEtM2QyY2NmYzlhYWNmIiwidCI6ImJjOTljZTFhLWYwOGEtNDY4Yy1hOGJlLWI0NmQzZDUyMzRhNiJ9

When I open this page on client from xibo library or browser it loads successfully but when xibo player try to opens it I receive this error as the screenshot:

Hi dbrifox, welcome to the community!

Some users have found that displaying Power BI using the standard webpage widget does not always work as expected. It is instead recommended to embed your dashboard, which allows you to create an iframe to be used with the embedded widget available in Xibo layout designer. Below are links to the documentation for Power BI which explain how to create an embeddable version of your dashboard. Please note that access to this functionality may not be included in your current Power BI account. If you cannot locate these options to create an embeddable version of your dashboard, you may need to discuss this with Windows.

Power BI documentation:


Xibo Embed widget documentation:
https://xibo.org.uk/manual/en/media_module_embedded.html

Many Thanks.

Hi @DanBW thank you for your reply.

I’ve tried to use embedded content as screenshot below:

It works on web page player but on windows client I receive the same error as the first post

Thank you for your reply and screenshots. I can see in your embed screenshot that the URL you are using is the same as the original URL in your post. In the second document I passed on, it explains how to receive an embed link that you can use in an iframe. Looking at the URL in the example images in the document I passed on, it appears to say https://app.powerbi.com/reportEmbed at the beginning of the address, whereas the address in your embed does not.
Did you try the method suggested in that guide or did you create that iframe yourself? If you created it yourself, please can you try the method described in the guide, as I suspect this could be why the content is not displaying correctly.

if this does not resolve the issue, you could also try adding the URl to the Edge Whitelist for your player, so it can use an alternative browser to load the content. To access the Whitelist:

  • Log into your CMS and go to the Displays menu.
  • Click the button at the end of the entry for your player and choose Edit from the menu.
  • When the Edit Display window opens, go to the Profile Settings tab and add the URL to the Edge Whitelist field:

Many Thanks.

The Xibo Community site uses cookies. What are cookies?