Player not downloading files

1.8-R6 on Ubuntu 20.04 (minimal).
The player has downloaded html files into the local library but that is it and it’s not displaying any content, just showing the splash screen. Here is the status screen on the player.

The server 2.3.9 running on Ubuntu 20.04 server. I’m using apache for SSL. Here are the last 50 log entries for that player.

Any thoughts on what is going on and what to check? I’ve never been able to get the Linux player to work. Windows player works just fine, and when I was running Android players those worked fine as well.


Made some progress. I have my server setup with apache2 redirecting all port 80 traffic to port 443. I set up a second server to test. I only have the new server set up for port 80 traffic right now and the linux client is working fine so far. I kind of figured it has something to do with the https setup. Next will be setting up SSL. On my primary serve I have my apache2 config set up differently than what is in the current xibo setup guide so I’m have to do some testing to figure out the best method that will work with our company’s wildcard cert.

Update - Fixed.
It was an https issue. On my primary server I had RedirectMatch permanent /(.*) https://server.url which worked fine if you only needed https to work. That works fine with the Windows client but caused problems with the Linux client.

On my test server I set up apache to proxy 80 and 443 and did not include that RedirectMatch line. That worked for both 80 and 443. I then turned on the force https in Xibo and things were redirected correctly. After doing some testing on the test server I called it good and made the same change on the primary. Everything seems to be working fine and I can now get linux clients (well only one for testing right now) to communicate correctly with the server.

Still wish this was more obvious and documented. Oh well, it works. Now to forget everything I learned and go back to my normal job.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.