Player keeps on downloading - CMS works, XMR issue?

CMS Version

CMS is 4.0.10, on Linux (docker)

Player Type

DSDevices 9x

Player Version

R403

Issue

We switched from a Windows virtual machine on-premice CMS to a cloud Linux CMS, which hosts our other services.

Docker-compose up goes without an issue, the only change from defaults is the port - 81:80, which is proxied by nginx to our domain and ports 80 and 443 for SSL and the domainname for cms-web. As for the XMR it is on the standard port 9505, which is open in ufw (allow tcp 9505).

I can access the CMS, and I have registered the display - upon entering the code, it wanted to connect to CMS on localhost:81, but I manually changed it to our domain. And it is accessible and the player is seen in the CMS. But the player doesn’t download resources - it doesn’t show any errors, nor is there anything in the log, it just keeps on downloading.

What can I do to check if XMR works properly or to make the display download resources? Even though on status it shows it is up to date, but “missing dependencies”.

Hi @roklipni

Could you please take a sreenshot to your Android Profil (“Display Settings” menu) ?

Check your XMR address here:

And if “Force HTTS?” is checked to “Network” tab.

Or check into setting menu and Display tab:

image

Thank you.
Under Android profile it is set as:

With force https as well

As well as in the Displays tab

Should I have set it some other way?

Do you have something to “Advanced → Logs”

And take a screenshot “Displays List”

I’d like to check that the player’s IP address is the same as the one in the player’s logs.

This is not an XMR problem.
Layouts and media are downloaded using the XMDS protocol (HTTP/HTTPS GET request).

OK, thank you.

Nothing in the logs:

The displays list is like this:

That’s what I thought, the IP address of the player is different between the list of players and the player logs.

Player logs: 153.5.199.97 (Strange that you use a public IP on a player)
Displays list: 172.19.0.1

You are probably using a reverse proxy that changes the source IP (player) of the request.

I had the same problem with Traefik. You have to set the input port as “Host”.

1 Like

Yes, that is it!
Thank you for your time and patience, it is working now :slight_smile: :partying_face:

Had to input host:

location / {
    proxy_pass              http://127.0.0.1:8080/;
    proxy_set_header        Host                    $host;
    proxy_set_header        X-Forwarded-For         $proxy_add_x_forwarded_for;
    proxy_set_header        X-Forwarded-Proto       $scheme;
    client_max_body_size 4G;
}
2 Likes