PDFs Not Displaying - Clean install - CMS 4.0.2 / Docker / Windows Player v4 R400


I have a clean docker-install of CMS 4.0.2 as well as two clean Windows Player v4 R400 installs on different Windows instances (10 & 11). Although the PDF-module in the CMS correctly displays the PDF’s content (and “slideshows” through its pages) in the layout-editor, neither of the players will display the PDFs. Meanwhile, in the same layout, I have an MP4-video which plays without any issues.

The Player clients have the latest Adobe Acrobat Reader versions installed (had been missing from one instance I was troubleshooting from, and I’d installed it in hopes the PDF would show up in the Player). I have also verified that the PDF was successfully retrieved by the clients, and that the PDF’s permissions on the clients match those of the MP4 that’s playing as expected.

I am a very new Xibo-user as I began searching for a signage-solution last-week. My limited experience has been a few brief days using Xibo for Docker 3.3.8 and Xibo for Windows v3 R310 . I had no issues using the these older versions on the same hardware I’m having issues on now. I’m also a bit concerned that maybe I’m overlooking something since I recall needing to set-up regions in layouts to accommodate the PDF-widget drop-in which is now missing from the layout-editor sidebar.

Here’s the layout which includes a PDF and an MP4; the PDF displays its 3-pages sequentially in the layout-editor. The PDF and MP4 play as expected when in “Play Layout fullscreen” local-mode. Notice the “No data providers configured” message in the PDF preview. I saw that there was a PDF-display issue in CMS 3 which required Module “validation” to correct, but this option’s not available in CMS 4:

Here is the same layout with the PDF-module preview disabled:

Here’s a screenshot of the layout playing on one of my Windows clients. Notice that there is an MP4-file in the debug-info, but no image/PDF-data; just a mysterious “Widget undefined” :

Here’s a file-listing in the /Library/ of one of the clients; notice that the PDF exists, and its permissions match the MP4. I also confirmed that the client’s version of the PDF isn’t corrupt.


After more troubleshooting, observing the lack of a PDF-file showing in the Player’s debugger may have been hasty; it showed up on my other client, but still no PDF-display. Also of note: the PDF’s duration is 60-seconds, and the MP4 is 31-seconds; the MP4 does pause for 29-seconds while waiting for the unseen PDF to finish its cycle.

Any guidance would be greatly appreciated.


Thanks for reporting this issue, I can recreate it also. PDF was working for 4.0.0, so I think it must have been broken as we fixed other things.

We will investigate and get it resolved.

EDIT: the root cause of this issue is a fix to the Dashboards module which unfortunately made it so that the PDF module (and others) expect to have a data file before they will be displayed. Of course no data file is available and should not be expected - this is why you get “No data providers available” in the editor.

We will come up with a better fix for the dashboards module, and retest that PDF is working after.

Thanks, Dan! Very impressed with the product regardless.

That’s good to hear - you’ve arrived here just as we’ve released a major version (18 months+ work) and so there are some teething problems :sweat_smile:

We’re getting them resolved fast, so I hope you stick around and get to see the system running normally.

1 Like

Any update on this or a work around until patched?

Latest updates didn’t fix it for me. I installed new CMS and new player.

To anyone else having issues. Make sure to set the Campaign to run again. Only after I updated my Campaign did the displays work.

As John says, the 4.0.3 update should have solved this issue, but a draft/publish of the layout is needed due to the error being cached.

Alternatively you may manually delete the widget cache from the CMS library folder. shared/cms/library/widget/*.html. If you know the widgetId you can delete just that file, or if not you can delete all html files in that folder.

4.0.3 solved my problems!

Thanks Dan and team!