PDF not displaying after 3.1.0 upgrade

To be completed by the original poster:

CMS Version

Xibo CMS 3.1.0 (Docker)

Player Type

Xibo Player for Windows

Player Version



after upgrading Xibo CMS to v3.1.0, it doesn’t display PDFs any more.
This is for Design, Preview, Library-Thumbnails and for the live client.
It only shows a blank white page.
Was still working fine in v3.0.x

I can still do stuff like upload/download in the library. After download to local PC, PDFs open just fine in Reader.

Any ideas ?

I had the same problem, after dropping the player cache and a manual run of the daily maintenance everything was back to normal a few hours later.

I had the same problem.


We have the same problem,

Any issue pls ?


I have the same problem PDF’s not displayed on clients - just a black screen and not thumbnails either. All since updating to v3.1.0

I have uninstalled the client and deleted its local library.
Run the maintenance tasks listed about, but didn’t get any visual feed back on these.

Please try Verify All for Modules and then clear cache after upgrading.

We have the same error here with Xibo Server 3.1.0 on docker install and Windows client version 3 R303.0-303 or linux client 1.8-R6-108.
Test reinstall all clients, clear cache, …
Is there a solution ?

Updated to 3.1.1 but same error !

Have you clicked to Verify All from the Modules page?

Yes, I’ve done it, but PDF don’t appear on clients

You may also need to try clearing the cached images and files in the browsing data settings for your browser.

Do let us know if this resolve this issue for you :+1:

After update to 3.1.1, there was an error with share rights !
After applying all corrects rights on files, all is OK

Glad you are up and running :+1:

Hi All

I have been having the same issue as described here - since updated to the CMS v3 (Linux docker) PDFs stopped displaying in CMS preview, layout designer as well as Windows Player (all worked well before the update).

My current set up: CMS 3.1.2 (Linux Docker) and Windows Player 3 R303.0 v

On the Windows machine that runs Windows Player I can see the pdf file as well as pdf.js file but Player displays black screen.

Any suggestions please? How can I test what is wrong? I checked Share options but it looks fine to me - what I should be looking at.


Have you used the Verify all button from the Modules page of the CMS and performed a browser cache clear? You may also need to clear cached images and files in the clear browsing data settings.

1 Like

I think this is working again, I did following steps that I think fixed the problem:

  1. Verify All - did not work
  2. take the Docker down - changed library chmod 777
  3. docker up and Verify all finished this time
  4. take the Docker down - changed library to chmo 755
  5. docker up and PDF old and new seems to be displaying


Confirming the fix to be:

  1. Administration/Modules > Verify All
  2. Clear browser image cache
  • e.g. Shift+F5 in Designer or via settings

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.