Not displaying RSS images


#1

For some reason, when I embed images from an RSS feed, they won’t display on the Android player. This used to work, but for some reason it stopped working. The image does show up on preview, but not on the Android player. No error messages in the logs.

I tried reinstalling the server, using a different server, using different hardware for the player, using HTTP and HTTPS, rebuilding the layouts, reverting back to stock templates but no luck.


#2

Can you confirm what version of Xibo for Android you are using? Also have you tried using the Ticker Widget to display your RSS feed?

If you can export the Layout and provide me a link to download it from (in a Private Message would be more secure), I can test it on my Android Display for you.

Many Thanks.


#3

I’m running the most current version.

Here is the layout:
https://www.dropbox.com/s/a42pek0d3lcrd1t/export_rss-nieuws-2.zip?dl=0


#4

Thank you for the link to your Layout. I have downloaded the Layout onto my Android Player and it is Displaying without issue. All 3 of your Tickers are returning the requested data from your feed, including the images in the main region in your Layout.

Can you specify the actual version of Xibo for Android you are running, just in case it is not the Latest version? Also, what hardware device are you using for your Android Display? Is that device up to date and has a stable network connection?

I would recommend selecting the Displays option in your CMS, clicking the down facing triangle at the end of the Display and choose Edit. Next select the Advanced tab and set a period of time in the Auditing Until field so that you can capture logs from the Display whilst the Layout is scheduled. If possible, I would recommend making sure that no other Layouts are scheduled on the Display so that you can see any errors or messages relating to this Layout easily. You can then view the logs in your CMS under the Log option, to see if any errors or other messages are being generated that would help to locate the cause of the issue.

Many Thanks.


#5

Xibo version is 1.8.R108. CMS was upgraded to 1.8.12 today. It has a stable network connection. I’m running it on an HP CB1-020ND (Chromebox) with the most recent updates and a TV Box MXQ. Both have the same issues.

Here are the logs:
logs.pdf (67.5 KB)

Here’s a picture:


#6

The issue you’re experiencing is likely related to the hardware you are using.

Your Chromebox is likely running Chrome OS, which is not a supported platform for the Xibo Player. I also looked into the MXQ TV box, which runs Android TV, which is also not an officially supported OS.

I have included a link below to the recommended Hardware for Android Guide, which provides tips as well as examples of recommended hardware:

Many Thanks.


#7

Like I said, they both used to work fine. Till one day the player stopped downloading new pictures and only displayed the cached pictures. Here’s a screengrab from a couple of weeks ago, running on the Chrombox.


#8

I understand that, my point is that Xibo for Android is not officially supported on Chromebox (Chrome OS) or Android TV. Because of this, we cannot guarantee performance.

Have you made any changes to your setup since it stopped displaying correctly, for example any updates to the OSs?

Many Thanks.


#9

Only thing I can think of is enabling ‘Force HTTPS’ but I can’t pinpoint that as the source of the problem. Already tried disabling it, but no luck.

Just to make sure I wasn’t going insane, I booted up Bluestacks to confirm. It runs fine on Bluestacks, so it looks like it is in fact the OS.

Doesn’t explain why it worked before, but can’t bother you with questions on unsupported hardware.