New Xibo Client 1.7.8 always on top

It appears with the new Windows client it is set to always be on top. When I try to run task manager it runs behind the Xibo client. In 1.7.6 I was able to run task manager for example and it would always be on top. Normally this wouldn’t be an issue because in most setups you could just kill the client with alt+f4. This however does not work in my situation as I am running Xibo as a shell which has been setup to restart when closed. This makes it difficult to make changes to the Xibo client configuration especially since the config is attached to the local account. When I tried editing the config file from another account it caused the player to flicker and wouldn’t load my layout.

Also I noticed the watchdog is set to always run with no option to disable it. As mentioned above I am using a shell that auto restarts when closed so the watchdog is not needed. I prefer to let the shell do the restart as we have other Kiosk type setups that use this method and would prefer not to create special setups.

Yes, you’re correct it is set to be always on top - we were specifically asked to do that.

What you can do:

  1. before you start it, you can open Options and make changes
  2. if 1) is not possible, you can go to display settings page -> edit display profile assigned to your device -> location tab -> change the dimensions so it doesn’t cover full screen - you will probably want to create new display profile with specific dimensions and then change between them if needed.

As for watchdog, if you don’t need it, you can disable it, please see:

Hi Peter,

Problem is because I’ve automated the install of Xibo I don’t actually have the chance to enter the details for my Xibo server which is the issue. Is there a way for me to edit the config settings from an account not running Xibo? I did attempt to do this but for some reason Xibo went balistic when I created my own config file. Deleting the file let Xibo function as normal but again in the same position where I can’t enter my servers details for the client to connect.

Ideally it would be nice if the config could occur in the client itself using a keyboard shortcut in the same fashion you are able to view the client stats.

There’s no reason that I know of that you can’t directly edit the config file. Perhaps you made a syntax error that made the configuration invalid?

You also need to ensure that the original user retains full control of the file permissions as Xibo will replace it with settings downloaded from the CMS on first run.

I noticed the same things as well. Disabling the watchdog is no big deal. However, the player always being on top is a big deal in my situation. Is there a way to change that in the settings somewhere?

Or

Can I use an old client version with CMS 1.7.8?

We are starting an external application using a shell command and the application is always moved to the Background because the XIBO Client always comes back to top. Is there some Workaround to prevent xibo from always staying on top?
It could be implemented as option to let the user choose if the application should always be on top.
Any idea how to solve this?

Hello is there a solution that Xibo is not allways on top? I updated our system from 1.7 to 2.1 now and now i have the problem on our windows clients that Xibo is always on top. We are using in our stores PCs with two displays and one of the displays is a customer screen. So if our worker want to show something to our customers they push the browser window to the customer screen and in the rest of the time our advertisements run there. Now Xibo is over the browser window and there is no possibility to change it. I also activated the mouse cursor which enabled the browser window under Xibo 1.7 but now i only see the mouse cursor and no browser window. Is there perhaps a registry hack to stop this?