New 1.8 CMS on U16.04.04LTS/Docker

The link from the install walkthrough takes me to the Docker site, where I find that the reason the stock Ubuntu Docker (which appears to be 1.13) complains in -compose is because Xibo wants Docker 2…

which appears to be commercial these days, and not FOSS anymore at all.

Am I missing something, or did I miss something?

Oh. The link defaults to EE, not CE.

Nevermind. :-}

Ok; different problem.

I’m following the instructions at:

and the step:

sudo apt-get install docker-ce

returns

jra@pano:/appl/downloads/xibo-docker-1.8.9$ sudo apt-get install docker-ce
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package docker-ce is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'docker-ce' has no installation candidate

Huh? :slight_smile:

Oh, are there really no packages built for 16.04LTS?

jra@pano:/appl/downloads/xibo-docker-1.8.9$ apt list -a docker-ce
Listing... Done
docker-ce/xenial 18.03.0~ce-0~ubuntu amd64
docker-ce/xenial 17.12.1~ce-0~ubuntu amd64
docker-ce/xenial 17.12.0~ce-0~ubuntu amd64
docker-ce/xenial 17.09.1~ce-0~ubuntu amd64
docker-ce/xenial 17.09.0~ce-0~ubuntu amd64
docker-ce/xenial 17.06.2~ce-0~ubuntu amd64
docker-ce/xenial 17.06.1~ce-0~ubuntu amd64
docker-ce/xenial 17.06.0~ce-0~ubuntu amd64
docker-ce/xenial 17.03.2~ce-0~ubuntu-xenial amd64
docker-ce/xenial 17.03.1~ce-0~ubuntu-xenial amd64
docker-ce/xenial 17.03.0~ce-0~ubuntu-xenial amd64

Or are those docker version numbers somehow?

We have a complete guide for Ubuntu 16.04 here:

You’re sure your system is 64 bit, as Docker won’t work on 32 bit installs.

Oh bother. Yes, I’ll bet you cash the machine has a 32-bit install. Oops. I know I had a good reason for that when I did it, but I don’t remember what it is anymore.

Nice catch, thanks.

The Xibo Community site uses cookies. What are cookies?