MySQL Problem while installing xibo 1.7.5

Hello,
I currently install Xibo (V1.7.5) in win 7 32bit.

When I try to install, Xibo said me I need “MySQL support must enabled in PHP”.
How can I to solve this problem ?

Exactly as it says, you need to enable PHP support for MySQL databases.

Google will tell you exactly how to do that, but the short answer is in your php.ini file, uncomment the line enabling the mysql extension, then restart your webserver.

I’ve already uncomment the line ,

is that right ?
and also restart my webserver, but it doesn’t work yet.
i’m so sorry, i’m still learning about xibo.

That looks right to me.

PHP’s instructions also say:
Also, be sure libmysql.dll is available to the system’s PATH. For more details on how, read the FAQ on setting up the Windows systems PATH. Because libmysql.dll (and many other PHP related files) exist in the PHP folder, you’ll want to add the PHP folder to your system’s PATH.

So perhaps the PHP folder isn’t in your system’s PATH environment variable? Or perhaps it is but you haven’t rebooted since it was added?

hi…
the problem was solved.
I try to uninstall xampp, and I install with the old version.
and it work !!
by the way, before I uninstall I try to cheking the system’s PATH and then reboot, but also it doesn’t work. until I uninstall and reinstall with the old version.

1 Like

Glad you have it working now. Thanks for the update.

The Xibo Community site uses cookies. What are cookies?