Migrating server - blank screens


I migrated my 1.8.5 Xibo to WAMMP and after a bit of tweaking it ‘seemed’ to be working but I have a coupel of issues.

I followed the docs to migrate and got to the stage of changing the library location. Whenever I changed it to a file path… say “d:/shared/” it kills the and I can’t use it anymore so I set it to /VertrigoServ/shared/ which is instide my WAMMP server and seems to work, The thumnbails and layouts all started working and it seemed like I have a solution. When i upload a new media it appears int that folder too.

The issue I have now is I can’t make any new displays or edit any as they are all showing as blank… no matter if I add text of images the preview always shows as a blank screen. I’ve tried simple ones too and the layout is showing green and ready but clicking the preview its showing as blank… weird.

Have I missed a change in the DB I sould have made? It ported over all the users and settings fine so am a little stuck.

I’m running the WAMMP on a windows desktop and everythign was rticked when I installed.

PS. I’ve changed it to d:/xiboshared/ and copied the library files across and when I upload files they appear so it all looks good.

I create a simple layout with some text and when I add it in the region it shows but when i click back into the desinger window its blank… weird… and the preview is blank too.

Looking at one I previously made I can see the jpg in the designer window (so image seem to show up) but the preview is blank too


One thing I did notice is that when I initially install the DB the library setting is visible in the GUI, when I restore the db and the option to upgrade appears then there is no setting visible… the box vanishes.

If you directly change that value in the database, you’ll need to go to the Settings page in the CMS and click Save to clear the settings cache before it will be respected.

The path must be fully qualified, and end in a / character, so what you’ve written above may work. I think typically on Windows it would be d:\xiboshared/ however.