Max size of JPG-Media?

Hi,
i would load a image with 1,5 MB into the media-bibliothek, but i get the message that the file-request is too large. Why this ? In the top it stand every file can be max. 2GB.
I don’t understand this. Can you help me?

regards
chris

For Docker based installs it’s not a problem with the CMS as it’s pre configured correctly. If you are using a reverse proxy, you would need to make sure that it will allow client body requests larger than the CMS has its upload size set to.

If you have a custom install then the following article may be of use to you: https://xibo.org.uk/docs/setup/how-do-i-upload-files-bigger-than-2mb-how-can-i-increase-the-upload-file-size-limit

We would need further information to be of more assistance but based on the error, it’s most likely an nginx reverse proxy which needs to be configured to allow larger requests.

Hello,
yes we use a docker based CMS and there was the default size 2GB but our test file only have 1,2 MB !
I tried it much more but just I come over 1 MB I get the message I send you.

As Natasha says, the error you’re seeing comes from your reverse proxy. You need to allow larger requests there. It isn’t an error coming from Xibo itself.

Hello,
Since my colleague is on vacation, I should now take care of our Xibo Docker installation.
Could the limitation of the 1 MB files for the media library be defined in this php file?
It is located in the / srv / / xibo-custom folder. We currently use Vers. 2.1.0

No it can’t be changed there.

If you’re using Docker, then the setting is in config.env. You’d need to edit it there, and then down/up the containers to apply that.

The default on a Docker install is 2GB, so I doubt it’s your issue. If the upload form says it takes files up to 2GB/4GB then your issue is not with Xibo, but with your reverse proxy.

Thank you, we can solved the problem. we must config in the reserve-proxy the right size.
Now it runs.

regards
Chris

The Xibo Community site uses cookies. What are cookies?