Manual install 1.8 rc2 Linux debian

I’m having trouble with my 1.8 rc2 demo installation

I have setup new linux debian (latest version)

I followed installl instructions

Install Apache 2.x Webserver   -->> sudo apt-get install apache2

Install MySQL Server -->> sudo apt-get install mysql-server

Install PHP5 :-->> sudo apt-get install php5 php5-mysql php5-gd

after that CMS install

Secure by design, the CMS has a folder structure which intends for only the web folder to be in a location served by the web server. This means the web server / hosting must allow files to be placed outside the web location.

-> I have put the cms directory into “/opt/xibo” and created “/opt/xibo-library”
-> created symlink from /opt/xibo/web to /var/www/web

sudo chown www-data.www-data -R /opt/xibo/web
sudo chown www-data.www-data -R /opt/xibo-library

changed /etc/apache2/apache2.conf

<Directory /opt/xibo/web>
    AllowOverride All
    Options Indexes FollowSymLinks MultiViews
    Order allow,deny
    Allow from all
    Require all granted

changed default site config

DocumentRoot /var/www/web

-> restarted apache

but when i go to http:\mymachine -> i’m redirected to http:\mymachine\install -> blank page

any suggestions on how to fix this ?

You might need to enable mod_rewrite on a vanilla install

sudo a2enmod rewrite
service apache2 restart

Aside from that, there is no need to symlink if you’ve mapped the folder using the <Directory> directive - in fact it might be confusing as you have 2 things point to the same folder (your DocumentRoot and your Directory directive)

A2enmod rewrite and restarting the apache2 service did not help

If you say the symlink is’t needed then I would have to change the documentroot ?

Ok fixed it.

I have moved my data to /var/www/xibo and /var/www/xibo-library
adjusted the apache2.conf
remove the symlink
adjust website.conf , set documentroot to /var/www/xibo/web

restarted apache no luck

then i did sudo chown www-data.www-data -R /opt/xibo
after that it did work …

case closed

1 Like

I’m not sure why that worked to be honest, but I am pleased it did.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.