Localhost not loading page

Hi everyone,

I’m a newbie working with Xibo and I’m experiencing some issue. We had it up and running working in our office but the machine used for this was decommissioned last year during the lockdown and we lost everything on this machine (and the person in charge of keeping it updated left the company earlier this year). So, I was assigned to get this back up, but I’m facing some issues:

I managed to get Xibo docker up and running, as seeing in the image, but when I try to open the local CMS, it seems it can’t reach the page (I got it configured in port 8080). When I use localhost:8080, it can’t be found, as seen on the image.

My question: Has anyone come across with this issue? I’ve temporally disabled the firewall on this test machine, in case it is being blocked by the firewall, but still can’t reach it.

I tried to go through all the previous posts but couldn’t find a similar issue discussed in this community.

Thanks in advance for any suggestion/feedback/tips.

Hi and welcome to the Community!

What docker version have you installed? and what is the OS you have installed onto?

What is the result of the docker ps command or something that shows that the containers are indeed running?

Check that you are using the correct protocol by using https or http at the beginning of the address.

Are you able to access the login page by entering the IP of the machine it is installed on instead of using localhost?

Hi Natasha,

Thank you for the prompt response!

I installed Docker 4.2.0 (70708) on a W10 64Bit (1909)

I’m trying to run it on a local machine (for testing purposes, before working on the main templates and data for display). I’ve tried http & https, with the port 8080 and without it, same results. I’ve also tried the local IP used by the machine, same results.

I haven’t been able to reach the login page. Once I run “docker-compose up -d” and the CMS is fully installed/running, I should get to the login screen, but that’s not the case here.

Have you followed the guide and used port 80 (the default port) or taken note as to the Using different ports section, as explained in the docs here: Xibo for Docker on Windows 10 64 bit | Xibo Open Source Digital Signage

If it is still not working it would be good to see that the containers are definitely running.

Hi Natasha,

Thank you again for such prompt reply. Correct, that’s exactly the guide used for my test. Let me share some info, to provide some context:

If I load the Xibo container with Docker using the default configuration (ports 80:80 in the docker-compose config file), I get the errors on the images 1 & 2, and cms-web won’t run (image 3).

I updated the ports used by the docker-compose config file, using the ports 8080:8080. Once I update this specific information, all errors go away and Xibo docker seems to be up and running (image 4), but every time I try to load the login screen to access the dashboard, I get the error shown on image 5.

If I check the logs for the cms-web, it just stops at the “starting webserver” step (image 6).

A bit difficult to identify the reason for not loading, since I don’t see any visible error messages (or container not running).

The container is still running on port 80. If you want to map it to a different port you would need to use 8080:80 and not 8080:8080.

The ports section of a Docker Compose YML file lists ports in the format <host>:<container> - to move to port 8080 the declaration would be 8080:80.

Hi Natasha,

Thank you for the information. That certainly fixed the issue. I then got an issue with the password and followed some tips from other discussions and finally managed to access the CMS dashboard. We’re now up and running and ready to run some template tests.

Thanks again for the prompt assistance!

1 Like

Fantastic stuff :+1:

The community is the best place to take a look for tips from previous topics, but if you cant find the answer then please do open a new topic so that one of our members can try and help you out :slight_smile:

The Xibo Community site uses cookies. What are cookies?