Linux player newest


#1

i need to edit something in settings-custom.php
but i dont understand what i need to edit?

Pls help?

i have xibo 1.8.11 on linux 16.04 running


#2

If you’re running with Docker, then in the custom folder, you need to put the extracted middleware file, and then edit the settings-custom.php file and add:

$middleware = [new \Xibo\Custom\XiboForLinuxMiddleware()];

To that file, inside the <?php tags.

If you have a custom installation, then you won’t have a settings-custom.php file, in which case you can add the same as above to your settings.php file, again inside the <?php tags.


#4

thanks i did that
but when i start the player, the first time he asked for autorised. so i did that, but when i try the second time to start the player he said this:

terminate called after throwing an instance of 'boost::exception_detail::clone_$
what(): No such node (sizeX)
Aborted (core dumped)


#5

Did you definitely set a default layout?


#6

yes i set a default layout
or do i need to set a campaign?


#7

No you shouldn’t need to. Can you check the Display Settings Profile for Linux Players has sensible settings in it?

What platform are you running the Player snap on please?


#8

linux player isn’t showing in the display setttings, but i put
$middleware = [new \Xibo\Custom\XiboForLinuxMiddleware()];
in the settings-custom.php.

what do you mean the player?
i have the player and server on a linux 16.04 if you mean that


#9

That will be the problem then.

You should see a Linux player type and profile in the Display Settings. If you add a new Display Settings profile, can you choose Linux there?


#10

no there is nothing
maybe the path is not good?
/opt/xibo/xibo-docker-1.8.11/shared/cms/custom$
dis my path to the setting-custom.php


#11

That looks right, and that file should have been there already?

Also in that directory you should have extracted the middleware file?


#12

yes the file is right there
$middleware = [new \Xibo\Custom\XiboForLinuxMiddleware()];
but is it possible that this path not good is with my path to the file?


#13

If the file already existed (ie you didn’t create settings-custom.php), then that should be the right place.

If you had to create it, then it’s not the right place.


#14

i replaced the middleware string
now it works all
thanks for helping :slight_smile: