Linux Player - 1.8 R1 Released

The team at Xibo Signage are pleased to announce that our first release of the new Xibo Player for Linux is ready. This release works with Xibo CMS version 1.8.12 or later.


This is a companion discussion topic for the original entry at https://blog.xibo.org.uk/linux-player-1-8-r1-released/
1 Like

still getting a unexpected end of data error on 1.xlf(10)

My feedbacks on two hardwares :

1/ Intel Compute Stick 18.04LTS

  • Videos renders very slow
  • Need restart the client to update Campaigns changes
  • Sometimes does not display webtext (like the clock widget)

2/ Asus i7 Laptop 18.04LTS worked ok with the 1.8beta1
Impossible to run the player. Logs :

(player:6442): glibmm-ERROR **: 21:51:37.566:
unhandled exception (type std::exception) in signal handler:
what: No such node (layout)

Globals remark :

  • It could be a good idea to disable the mouse pointer
  • I found where to change the splash screen but it would be cool to make it a field in cmsSettings.xml

Hope all of those are useful
Chz all

Check the file contents. You should find it in the library location with name: 1.xlf. If the files contain HTML data I have the same error. The player doesn’t find the correct files and writes HTML error message (301 moved permanently in my case) to all the files it tries to download , thus the data it expects to load from the files is corrupted. Unfortunately I don’t have a solution to this problem yet.

EDIT:

I managed to get the player to run and display the default layout. Now I’ll just need to get it to update the layouts.
Changing the address from https://yourwebsite.com to https://www.yourwebsite.com did the trick.

Hi Xibo Team,

Faced below three errors in three different attempts:

  1. After authorized display from CMS and launched xibo-player first time:-
    Gtk-Message: 02:11:14.229: Failed to load module “topmenu-gtk-module”
    terminate called after throwing an instance of ‘boost::exception_detail::clone_impl<boost::exception_detail::error_info_injectorboost::property_tree::ptree_bad_path >’
    what(): No such node (sizeX)

  2. Gtk-Message: 18:05:36.586: Failed to load module “topmenu-gtk-module”
    [18:05:36.682] [002080] [error]: No such node (schedule)

  3. (gst-plugin-scanner:4949): GStreamer-WARNING **: 18:38:11.937: Failed to load plugin ‘/snap/xibo-player/19/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstaasink.so’: libgpm.so.2: cannot open shared object file: No such file or directory

(gst-plugin-scanner:4949): GStreamer-WARNING **: 18:38:14.180: Failed to load plugin ‘/snap/xibo-player/19/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstaasink.so’: libgpm.so.2: cannot open shared object file: No such file or directory
Gtk-Message: 18:38:14.470: Failed to load module “topmenu-gtk-module”
[18:38:14.620] [004890] [debug]: Player settings updated
[18:38:14.621] [004957] [debug]: Collection started
[18:38:14.623] [004957] [debug]: Scheme: 0 HostType: 1 Host: 172.20.92.70 Port: 80 Target: /xibo-cms-1.8.12/web/xmds.php?v=5
terminate called after throwing an instance of ‘boost::exception_detail::clone_impl<boost::exception_detail::error_info_injectorboost::property_tree::ptree_bad_path >’
what(): No such node (sizeX)

Thanks,
Amit

Yes, me too since alpha.

I do not think the software respects the address correctly. I have to run cms on a different port.

I’ve Ubuntu Mate on a Raspberry Pi 3B, but since it’s an ARM-processor, the Linux Player cannot be installed. Will the Linux Player also be available in the future for ARM-processors, or do I need to buy an other minicomputer?

Some news from here :

I have made some tests with many hardwares (Intel sticks, big nvidia PCs, VMs) with the same CMS (1.8.3), and two recurrent troubles are showing

1/ what: No such node (layout)
Ununderstable !
For example : on the same hardware, I work with 18.04lts and 19.04 images with preinstalled snapPlayer.
Loading 18.04 - running player : OK
Then
Loading 19.04 - running player : NOK (what: No such node (layout))
Then
Reloading the same 18.04 - running player : NOK (what: No such node (layout)
LS in content dir : only 3 files have been dl (cachedFiles.xml moment.js xibo-image-render.js)
Restart the player : Still the error but the content dir shows all the files as if the displayer was launched before the dl fully done
EDIT : I need to make as the default layout “Default Layout” to run the client correctly, then remake the correct layout as the default to be desplayed (??)

2/ Is the watchdog (/snap/xibo-player/19/bin/watchdog) ready to work ? Or any script like the old ./run_always.sh ?
As we can see big crashes some times but the client can be relaunch manually

Hope all of this is useful
Rgds

Hello,
I have install xibo on ubuntu 18.04, it’s work but i would like to know how i can install the snap in silent mode (command line without use the xibo-player.options)
The pdf file doesn’t work it’s normal?
Thanks alot !

What I do :

Run one time xibo-player.options then close it. It creates /home/~/snap/xibo-player where you can find folders 19,common,current.
Then, I scripted the creation of the cmsSettings.xml file and its copy in snap/xibo-player/current/ containing :

Then you can run xibo-player.

1 Like

Thanks for your information.
But if the player is not register it’s doesn’t work because he will never send the data to the server for to ask to be register.
How did you pass this step?

The first connection makes an entry in ur cms, then you choose to authorize or not.

PDF support is coming with 1.8R2 due shortly

You can’t at the moment, but its a good idea, we will make a note of that.

We have an “auto-authorise” option in CMS settings which might suit your use case

Not quite ready yet - it is on the road map though

If you do not have a default layout, and you do not have anything scheduled, then I would expect the splash screen to show - are you seeing that isn’t happening?

I’m sorry but I am not sure what the errors are in your post.

Thanks for your answer, I am waiting for this update impatiently :slight_smile:

@pb7892 the watchdog doesn’t work but you can create a service like this :

cat <<EOF> /etc/systemd/system/start-xibo.service
[Unit]
Description=Service Xibo-client
[Service]
Type=simple
RestartSec=30
Environment=DISPLAY=:0
User=xibo
ExecStart=/snap/bin/xibo-player
Restart=always
[Install]
WantedBy=default.target

EOF

/bin/systemctl enable start-xibo.service
/bin/systemctl daemon-reload

In my case the user is xibo so you need use your user :slight_smile: .
I have build a full install by ipxe with kickstart (ubuntu 18.04), my last thing is to install xibo in command but soon i could do it.

I made my own one by PID watch

Ok, I think I got it :

When I try to load, by the default layout menu, a layout containing a fullscreen region with with a playlist of files, it returns
(player:3122): glibmm-ERROR **: 11:05:21.169:
unhandled exception (type std::exception) in signal handler:
what: No such node (layout)
When I try to load the same files in a fullscreen region, not in a playlist, but one by one in a video widget, it downloads and play correctly.

Not sure if bug report are read here, or on the github, but the Linux client does not take into account the custom port the CMS is on for all files ( beside .html )
So if the CMS is on a custom port, Linux client cannot cache files, most requests are “Connexion refused”

Hi guys!

I’m implante XIBO im my TV’s and now after installed Xibo Server, i’m testing and searching the better solution to run players in my devices together with TV’s.

What’s the recommend hardware to use Xibo Player Linux with images, HTML and texts in these devices?