Invalid layouts

Before completing please check that the time, date and timezone have been correctly set on the device running the Player.

To be completed by the original poster:

Player Version

1.8 r6 108


Any layout i try is invalid. layouts work fine on windows…

Provide screenshots where possible!

Hi There,

I have the same issue, except my windows displays aren’t working either. I have this funny feeling it started happening after a certain point, adding a second display triggered it and then it stopped, I have one existing linux display working fine but any new ones after that (windows or linux) doesn’t work:
client info shows invalid layouts no matter the layout

errors below(on portal):

|25343|fe246b4|2021-02-09 10:28|PLAYER|POST|ERROR|Test|[1509]|[CollectionInterval] [HTTP] 408 Request Timeout|
|25342|fe246b4|2021-02-09 10:27|PLAYER|POST|ERROR|Test|[1509]|[CollectionInterval] [HTTP] Connection reset by peer|
|25341|a1cc73a|2021-02-09 10:22|PLAYER|POST|ERROR|Test|[1509]|[CollectionInterval] [HTTP] end of stream|
|25340|930dc44|2021-02-09 09:54|PLAYER|POST|ERROR|Test|[1509]|[CollectionInterval] [HTTP] end of stream|
|25339|c9decf0|2021-02-09 09:43|PLAYER|POST|ERROR|Test|[1509]|[CollectionInterval] [HTTP] 408 Request Timeout|
|25338|8054729|2021-02-09 09:41|PLAYER|POST|ERROR|Test|[1509]|[CollectionInterval] [HTTP] end of stream|
|25337|8054729|2021-02-09 09:39|PLAYER|POST|ERROR|Test|[1509]|[CollectionInterval] [HTTP] end of stream|
|25336|305925f|2021-02-09 09:23|PLAYER|POST|ERROR|Test|[1509]|[CollectionInterval] [HTTP] end of stream|
|25335|4d90f47|2021-02-09 09:14|PLAYER|POST|ERROR|Test|[1509]|With XInitThreads|

I also get this error now when requesting screenshots:
|25351|8e55b54|2021-02-09 11:19|WEB|PUT|ERROR||/display/requestscreenshot/26|Unable to Process Queue of Player actions due to 1 of 1 player actions failed|

|25350|8e55b54|2021-02-09 11:19|WEB|PUT|ERROR||/display/requestscreenshot/26|Player action connection failed. E = Cannot seal message|

I have tried redoing the displays right down to re-installing OS on different hardware

I was also thinking to reset the CMS DB to remove any old references to old test displays, any ideas on how I can safely get that done?

CMS 2.3.8 Docker on Ubuntu 20.04(same on 2.3.7)
Clients Xibo for Linux - 1.8 R6 on Ubuntu 20.04 via Snap and APP IMAGE(same problem on R5 Snap and APP IMAGE)

Any help would be highly appreciated, Need to roll out a 100+ displays asap, I have replaced a Windows server running cms 1.8 with this one and can’t really go back as it was running on old windows.

quick update, when i bring up the xibo information window, and go to invalid files it lists fonts.css
i tried regenerating the font via xibo cms modules and it did regenerate but same filesize/permissions etc.

First take a database backup. Check the media table in the database. You should only have one entry with storedAs set to fonts.css. If you have more than one, take a database backup, and then delete all but the one with the lowest mediaID. Then edit each of your Displays from the Displays page and save to clear the display cache.

I would open your own thread as your issue is not related to the original poster’s issue.

That worked, Thank you Thank you!!

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.