Installing Xibo CMS on shared hosting

Hey all.

I am trying to install Xibo CMS on shared web hosting (
I asked the hosting provider if they support docker and ZeroMQ. Unfortunately they do not.

Without having to move hosting provider, is there a way to install it correctly?

At the moment i get an error when trying to put text into a layout or send refresh commands to the player.

Has anyone attempted this?
Any work arounds?

Whilst it is possible, we would not recommend using shared web hosting, as you may find that it does not provide all of the options you will need to set up your Xibo CMS.

If your host provider has confirmed that they do not support ZeroMQ or Docker, you would need to set up your Xibo CMS as a custom installation. If you are not able to install ZeroMQ, you will not be able to take advantage of the features that require ZeroMq, for example XMR, which pushes changes to your Players without the need to wait for the next collect interval.

You also mentioned that you are receiving an error when trying to send refresh commands to your Player, this is likely related to the fact that you cannot set up ZeroMQ on your host.

Without knowing what other restrictions your host provider has, I cannot say whether you will be able to set up Xibo successfully.

It is of course your decision but I would strongly recommend looking for an alternative hosting solution.

Many Thanks.

Well im trying it too… but i am a shared hoster (not for the person above ;)). I want to play with 2.0.0-beta but cannot seem to pass a 500 error at installing wich btw does not enter any data into my error log… So that makes troubleshooting a lot harder.

Server ubuntu 18.04
PHP Version 7.2.10

steps i took:
cloned and ftp’ed the folders to /client##/web##/web/
add a document root to /client##/web##/web/web/

i put a info.php with phpinf() into the new document root to test if all is still well… it is.

and from this moment when i expect an installer its 500…

** UPDATE **
run a composer install helps the 500 error :wink: BUT i still get a unstyled installer page with some 404 to some files that are not there.

  • /dist/style.bundle.min.js
  • /dist/vendor.bundle.min.js
  • /dist/js/install.js

** UPDATE **

npm install webpack
npm install
npm run build

solved missing files at first install page.

It now tested server needs and it says:
File System Permissions Write permissions are required for web/settings.php and cache/

the web/settings.php file is not there… creating an empty settings.php file wil not work… I red that its a file permission issue. but making the folder and file 777 does not make it work.

** UPDATE **

I think there is an error in coding.
Your using is_writable function wich not only checks if file is writable, but it also checks if the file exists… in a clean install this is not the case and thus always false. To overcome this problem i changed this:

on line 44 i changed:
return (is_writable(PROJECT_ROOT . “/web/settings.php”) && is_writable(PROJECT_ROOT . “/cache”));


return true;

after this i can go to step 2 of the install… (remember that i 100% know that my filepermissions are correct)

** UPDATE **

installation is complete! Im now running 2.0.0-beta in shared hosting enviroment. Looking into XTR and XMR in a few days.

PS after install is complete dont forget to revert the changed /lib/Helper/Enviroment.php back to what it was. settings.php is now created so the check wont fail any more!

My shared hosting supports Softaculous and Xibo is part of it. Installing the latest version is no problem.

my hosting does not support ZeroMQ or Docker…
which hosting do you recommend

need help , my hosting does not support ZeroMQ or Docker…
which hosting do you recommend

Hi Tarcizio, my apologies for my delayed reply. Here is a link to our document on hosting, which includes some helpful information on recommended hosting platforms and also requirements for a hosted solution.

Please also note that we offer hosting on our cloud service. If you would like to discuss this with a member of the sales team, please open a ticket.

Many Thanks.

As @DanBW said. Installing xibo cms poses a problem as hosting providers offer limited features.
But I installed it on normal cpanel and hosting system with many restrictions. You cannot send commands as there is no Zeromq support. Task scheduling is also executed at 15-minute intervals. There are database query limits. Despite such shortcomings, I use it for demo purposes.
If you really want to use it with full support, you will have to consider a server rather than hosting. This can also be expensive.
The hosting system that Xibo sells and that you can use with your domain name makes more sense. Or you can rent a docker server from digital ocean. This will also work for you.
Although it is limited, if you are going to install the hosting system, I will try to help.


Hi. Apologies, its been a long time since i checked back here. After getting Xibo working, i just left it.

I now come back as i need to make some big changes to the digital displays.

I am considering the Xibo hosting now.

HI CrazeUK. Thanks for the update on your setup. I was a little unclear about some details in your message:

  • Is your CMS working on the shared hosting service you originally asked about in your post?
  • What version of the CMS are you using?
  • When you say I now come back as i need to make some big changes to the digital displays, what are you referring to specifically?
  • When you say I am considering the Xibo hosting now, do you mean you would like to discuss hosting your CMS on the Xibo cloud? If yes, you can log into your Xibo portal account and then open a ticket here to make an enquiry with the sales team.

Many Thanks.