Installation Object not found


So left my old place and had xibo cms with 6 android devices running nicely. Have display requirements at my new job, but am stumbling on the on-premise install.

after the requirements check and you press next, it errors out at: /xibo/web/install/2?:

Object not found!

The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

If you think this is a server error, please contact the webmaster.

Error 404

did I miss something?

after looking at the error logs… lookslike Options followsymlinks and symlinksif ownermatch are both off, so the rewriterule directive is also forbidden…

can those be enabled just for the xibo folder in the .htaccess file?


You need to go back and read the install notes for a custom install.

If you have “web” in the URL, then you’ve installed the system incorrectly.

Unlike earlier versions of Xibo, only the “web” folder should be web servable by your webserver. The folders above that need to be there, but they shouldn’t be publicly accessible.

Hello, ppbevilacqua,
I had the same problem.

on Ubuntu 16.04

I turned on apache mod_rewrite:
sudo ln -s /etc/apache2/mods-available/rewrite.load /etc/apache2/mods-enabled/rewrite.load
sudo nano /etc/apache2/sites-available/000-default.conf
DocumentRoot /var/www/html/xibo/web
<Directory /var/www/html>
Options Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
allow from all

sudo service apache2 restart

and the problem was solved

1 Like


thank you for the information and help, I will give that a try.


Thanks that worked for me

worked for me…
only thing is I have to enter

i have to specify the web portion… but I’m happy its up and running

Id really encourage you to resolve that issue - there are files in the root of the app that you do not want to be web serviceable.

Got it the web url adjusted.,
working well.

1 Like