Information for CSV Formatting and Formulas

Hi Xibo People,

i’m currently struggling with importing a CSV file for creating a class and room schedule display. Is there any source of information on how to correctly format the CSV file for the use in Xibo’s DataSets and how you can use Formulas to only display certain portions depending on the time?

(EDIT: Sorry for confusing the Formulas with the Filtering in the ticker settings - i’m looking for things like the NOW() command - where can i find more of these filters?)

I found the very useful tutorial on the Meeting Room Bookings, but i can’t find any information on formatting and formulas…

Any help or information is greatly appreciated - thanks in advance!

Best regards,


Hi Sundance,

It shouldn’t be a problem to correctly import your .csv file, what seems to be a problem here?
as for the filter and order fields in ticker/dataset view they are using SQL syntax ie.

order: columnName or columnName DESC
filter: Day = ‘Monday’ or as in this example NOW() > StartTime AND NOW() < EndTime

depends on what columns you have and what you want to achieve.
You can have a look SQL functions if you want to know more.

Articles regarding datasets to read:


Hi Peter,

thank you for your quick reply and for pointing me to the SQL syntax, that’s part of what i was looking for.

I don’t quite understand the whole workflow of creating the dataset yet - i have a .csv file that contains date, room no., duration, teacher and subject in this order. I have uploaded the file, maybe you can take a look some time:

Now i want to map these 5 columns to the dataset in Xibo, to be able to display it in a Ticker for the schedule display (using the SQL filtering you mentioned above).

I have created a dataset and set the column order accordingly, but upon import of the .csv file, it maps everything into the first column…

What am i doing wrong?

Thanks again

Best Regards


before you import your .csv file, you will need to add more columns to the dataset (5 in your case) give them proper names, so it will be easier for you to make order/filter later on.

When you will have 5 columns there, import your .csv file and it should be fine.

Like this (but you will want better column names :slight_smile: )

My CMS is in english so it has problems with Ü character, it should be fine for you and if not then you might want to use u or ue (I think that’s the way to write it without actual Ü character)

Hi Peter,

thanks for taking the time to look into the file!

I had created 5 columns already actually, but upon import, i see the comma seperated files all in the first column:

What import settings do i have to take care of before hitting “Import” - am i missing something? Or do the 5 columns need special settings? I leaved everything to default…

Thanks again

Best regards


So, .csv file is basically text file with usually comma(,) separated fields.

When I opened it in my LibraOffice Calc it asked me how the fields are separated, then I selected comma (,) so it opened as it should then just save it and import that to Xibo.
With MS excel or OpenOffice it would be the same/similar.

As for the columns, you can set the type if you want, but I left it as string and didn’t do anything to it.

I hope that this will help you :smile:

I actually found the reason it didn’t work, thanks for pointing me to using libre calc:

My german excel version automatically uses the semicolon as a delimiter on .csv export, while Xibo needs the classical comma delimiter to be able to seperate the data.

I saved it with commas and now everything works as expected - i read online (click here) that the standard delimiter setting is depending on the system language settings, so i guess other poor germans might run into the same problem…

Thanks a lot for your kind help @Peter !!

Best regards