I need help with constant layout failure

hi community,
when creating layouts with client 1.7.1 (which i cannot update, as i have only access to the client via webinterface) i constantly get error messages of the following kind in my logs:

function: [FileAgent_media_Id_24] FileAgent - Run

message: Downloaded file failed MD5 check. Calculated [d41d8cd98f00b204e9800998ecf8427e] & XMDS [ e4e590e8a4068d1924d2a745a5a42cfc] . 24.jpg

the weird thing is, that it happens after a couple of days, when everything worked fine and i didn’t change layout contents. it happens with about eight of twelve different layouts and is always the same. i create layout, put content into region, in this case by uploading for example the pic essen.jpg with the id 24, everything is fine it just works. but then… see above. the layouts themselves are all valid, the regions are valid, the pics are valid.

the pic itself is 175 kb, has 10 sec. duration, and the library does not show any difference to other valid pics, that are already shown in there layouts.

what can i do? it makes me crazy, as the same failure appears since months with any layout i create and/or schedule.


It would be really great if you could upgrade both CMS and clients to the newest versions as soon as you’ll be able to do so.
After failed md5 check, player should attempt to download this file again at the next collection interval, does it happen?
While we are on it, what’s your collection interval and download window start/end time? (you can check that in the displays setting-> edit display profile that you device is using)

there are attempts which lead to a duplicated error log.

collection interval is 10 sec.
download window start/end time i do not find any in my display profile window. in ‘extras’ i find only
time for empty layouts 10
number of concurrent downloads 2
screenshot interval 0

how can i attach a jpg screenshot to a posting?

by the way, i’m german, my english is poor.

You might want to try to delete this file in the player local library, perhaps also delete it from CMS library.
After that upload it again to the CMS and add it to the layout, schedule it on your player let it download it again and see if that will help.

As for posting images, I believe you need to earn ‘trust’ level on the forums, which in this case means, that you just need to read some other topics to gain this level.

i have already read most of the topics in ‘support’, the whole bunch of documentation, regarding installation and so on.

the play with deleting file from region and library and upload with different filename, crearting new region, upload new file and so on is one thing i have done so many times, and it never lasted more than a couple of days, and then same story.

one more error message regarding the cms:

“errormsg” Undefined variable: type “/errormsg”
“errornum” 8 “/errornum”
“errortype” Notice “/errortype”
“scriptname” D:\xampp\htdocs\xibo\lib\service\xmdssoap4.class.php “/scriptname”
“scriptlinenum” 932 “/scriptlinenum”

the “…” is smaller as…bigger as
please note: i do not have physical access to the machine which is running xampp and xibo cms.

Ok, so the only reasons for md5 to be changed after it was already downloaded and working fine is if something is corrupting the file in the library, or something is changing the value in the database.

I think it’s more likely that it’s the storage on the Player that’s causing this problem.

There have been lots of fixes there in the later versions, so the best thing you can do is upgrade the Player.
I appreciate that it might be difficult for you as you don’t have direct access to this PC but it’s by far the best thing that you can do to fix this problem.
Deleting and re-uploading this file every few days isn’t optimal solution as I am sure you know, not to mention that you might have some more interesting things to do in this time :smile:

most of the better things to do is just doing my daily work here :wink:

okay, i tried to download one of the mentioned files and get the following message:

D:\files\xibo\24.jpg is not an image

which is definitely strange!

So that suggests that file is infact missing from the CMS library.

Perhaps somebody deleted it from the CMS library directory on your server? Those files must NEVER be touched. The only modification to them should be via the Xibo CMS itself.

there is just one thing: when i had access to the server’s library directory a couple of weeks ago, i just copied all files to a different location and opened them with irfanview with no problem at all. but it were different files then. see my first posting with me trying to get rid of about 700 files in the library, which were actually copies of copies of copies of… remember? okay, let’s see. i will try to get hands on the machine and install and setup the whole bunch including xampp, cms and player. then i’ll be back again.

but anyway, it is not the file missing, it seems to be a checksum error of a file, which is no longer recognized as ‘image’.