How to disable inactivity logout

After some time of inactivity, the xibo logs out automatically.

I would like to disable this feature, how should I proceed?

I want the xibo to log off only when I click log off

Hi,

You can’t disable this feature what you can do though is increase the timeout to something really big by adjusting the max lifetime

If you’re using docker you can control that with an environment variable: CMS_PHP_SESSION_GC_MAXLIFETIME=1440, otherwise you need to edit your php.ini file for session.gc_maxlifetime.

I do not recommend setting a really high value as it makes Xibo less secure.

Thanks,
Dan

If I edit the php.ini file as you suggested, it will impact all hosting sites, right?

Ideally, this would only affect the shin, to avoid this problem:

Its hard to advise you there as it depends very much how you have things set up on your hosting. I think you can apply php.ini settings per host though.

1 Like

Ok.

Thanks for the help.

1 Like
The Xibo Community site uses cookies. What are cookies?