Google Slides not displaying

We often use Google Slides as an alternative to doing presentations with PPT. It was working well for a while and then recently we started getting an error “This content cannot be displayed in a frame. To help protect the security of information you enter into this website, the publisher of this content does not allow it to be displayed in a frame” Nothing has changed with the Google Slides settings. Any thoughts on how to get this to work again? Below is a link to a test. Thanks in advance for any advice.

This means that Google have decided to not allow you to embed the content any more - so Xibo must open the content without manually sizing it at all (which means you need to have Zoom set to 100 and no offsets defined).

If it still doesn’t work it may be that google have provided an alternative way to embed the slides - i’ve no experience with this unfortunately.

It sounds like Google are preventing you from embedding slides in the way you have been doing.

Have you tried using the official Google Slides embed code:

So for example, to embed that presentation, you’d create a Webpage media with the URL:

I tried the different options (natively, manual, best fit) for displaying the linked slide show and all come up with the same error. I then tried using chunks of the embed code which did at least start loading the slideshow but would not actually load the content. I have yet to try setting up a separate webpage, embedding the slideshow in that and then displaying the webpage. That is next on my list. I have a feeling that is going to fail as well but it is worth a shot.

This is definitely a bummer because we were finally gearing up to start phasing out PPT and moving everyone over to Google Slides. I may be back to looking for cheap and reliable alternatives to PPT again. Thanks guys for your advice. I’ll chime back in if I get anything to work.

I’m pretty sure if you just put that in as the URL to a webpage media it will just work.

Yes, that works when I try it:

And here’s the URL for your test layout (which also works for me embedded the same way):

Yep, that works. Thanks Alex and Dan. You guys rock. I’ll keep testing it but that simple swap of d/ for embed?id= in the url seems to fix the problem.

1 Like

This is mostly for others that may be searching for this same type of solution. So on further investigation I’ve concluded that I’m an idiot. Yes it is possible to display a google slides presentation via the webpage option. It would require changing their provided link a little bit but it is a viable option. In fiddling around with other google products (youtube mainly) I happened to glance at the other media options and it finally sank in that you guys have an embedded option. Forest for the trees man, forest for the trees. So google provides options to embed into websites which is generally an easy copy and paste deal. For the most part their code works. You may need to add something to their code. For instance for youtube videos you have to add autoplay=1 to get the video to autoplay and for slides you may have to modify their frame dimensions. Not entirely the most user friendly workflow especially for users that may not know what any of those options actually do, but it is more in line with what google intends and is probably more reliable in the long run. Looks like I will be writing up another guide for my users.

Hopefully this helps others and if anyone has an easier solution I’d love to hear it. Thanks again Alex and Dan.

Ultimately the best solution is a module called “Google Slides” and a module called “YouTube”, etc, etc. We are kinda hoping that now we have a nice discussion area people will say “hey, can we make this embed code we use into a module” :smiling_imp: