Free player freezes TV

Just wondering if anyone has experienced this. I’ve read through a few of the topics and can’t see what, if anything, I have done wrong.
Spec: TV: JVD LT-40CA890
Player: Xibo for Android v3 R305 (trial version)
I uploaded the player to the TV and then ran the player. It installed itself in the systems app (I had no control over this) and whilst it was installing, I gave the player permissions.
Now I authorised the TV after putting in the CMS code and the TV was recognised. Then I sheduled a player for that TV and it showed up for 10 seconds. Since then the TV has frozen up. Nothing works, not even the other apps. I’ve restarted the TV (Powered down and waited) and there was a marginal improvement, but after a few seconds the whole TV froze up. Now as I have three of these, I tried the same on TV 2 and it reacted just the same. No player and froze up the entire TV.
At the moment the only option I have is to try and discover a hardware reset as I can’t do this through the remote.
I’m sure I followed the instructions properly. Anyone have a clue what might be going on?
Any help is much appriciated.

OK, I’m going to follow up on this.
Resetting the JVC TV was extremely difficult as the TV screen had frozen in the Home Screen mode. But luckily it was possible to hear the selection the remote was using.
I mentioned that I had three of these TV’s, and so I switched on an unaffected TV and then used that one to show the path to select menu sequence from the blind TV and eventually was able to factory rest the TV.
I’m not one for giving up on things. So I downloaded the app from my Android phone to the TV and re-installed Xibo. This time it worked well.
I took a closer look at the second TV I had that had and this one was fresh out of the box. I installed the Xibo player and BAM! frozen up. Knowing how to reset the TV having done so already, I then installed Xibo to the second TV and it works well.

So I guess best practice is to factory rest the TV before installing the Xibo app on the model TV’s I have. I can only guess that there is an app that doesn’t play well with the Xibo player and that factory rest clears that issue.

Now that that is out of the way… Time to make some awesome digital menus and share what I can and help wherever possible.