Forecast IO behind proxy

I have problems with Forecast IO behind proxy. I made a topic on github with this problem:

Forecast IO Behind PROXY

There is solution but the solution doesn’t work for me. I’ll hope someone can help me.

I can’t find anything in the error report. The only thing i can find is that the twitter api can’t be found.

I think the first thing you need to do is take a step back and check:

  • Proxy settings in the Xibo CMS are definitely correct (and have no leading/trailing spaces etc)
  • Your proxy definitely isn’t filtering or blocking these requests
  • You applied all the patches in that previous thread correctly
  • You enabled debugging and auditing on the CMS
  • You clear the forecast IO cache as mentioned in the previous thread
  • Try adding a forecast media again from scratch, and if it’s still not working, post up the complete log (with any keys or other sensitive information redacted)

The proxy settings are right because the rss feed works very well. So i think there is something wrong.

But what i have done is copy the 2 files and overwrite the old ones. I set debugging to enable.

Already tried to clear the forecast cache.

You need debug and audit set to on. Then create a new forecast and post redacted logs.

Without any logs this isn’t going to be something anyone can help you with I’m afraid.

I have made a debug file:

But i can’t find it.

It says the log is 0KB?

That’s not possible. Perhaps you have an issue in your database too? Are any logs written? There should be hundreds with auditing turned on

I see the file is 122kb but i don’t have hunderds of them. Where do i need to find the logs then ? I used the Report Fault there i enabled the debug option.

When I try to download the file you uploaded it says it’s 0KB

Could you try uploading it somewhere else please or try uploading it again?

I’ll hope this one works:

We need to try and get some more error logging from Xibo to see why the request is failing. At the moment all we get is an error code 0, which means “host not found”.

I have added some extra logging to this file. Can you please patch that whole file in your CMS installation and then repeat the procedure you used to generate the last troubleshoot.txt file (it contained the correct logging, so repeat the procedure exactly).

Hi Dan,

Thanks for the help i updated the file and this is the log:

So the error is:
“2015-03-12 16:03:50”,“Forecast\Forecast”,“request”,“Unable to reach Forecast API. No Host Found (HTTP Code 0). Curl Error = SSL certificate problem: unable to get local issuer certificate”

Sounds like you need to setup your certificates for your PHP installation:

Alternatively that could be because your proxy server is doing SSL bumping (where SSL connections are intercepted for filtering/auditing purposes) in which case you need to get your organisations root certificate added to the certificate bundle file (from the article I just linked) so that PHP sees the connection to with your organisations faked certificate as valid.

Thnx for the help i will look into it :smile:

I have installed 1.7.3 and the exception seems to be work perfectly. (Do ya’ll have a donation page?)

I’m still working through getting the Forecaste IO to work.

Here are the audit logs I am getting:

I have reset my API Key multiple times. Is is possible that an older key is cached and not the newer one?

We do have a donation page here:

Could you capture fresh logs please from 1.7.3 CMS and then we can see what the issue is. Use the report fault wizard to generate a troubleshoot.txt.

You should redact any sensitive information

1 Like

What’s the best way to send you the .txt file?

You could use a dropbox, google drive or similar - any service that allows you to upload a file and then share a public link. Personally I use dropbox :slight_smile:

Please can you fix the issue with your filesystem permissions first, then run this again with a layout with just the Forecast module on it. Wading through all the other logging from your other regions is really tricky!

I’ll work on the permissions issue today and reach back out with the results.