Forecast: change language of 5 days


Yesterday I had a problem with changing the language of the 5 days.
I got a reply from Peter saying:

In CMS settings, regional tab:
language - set your preferred language (for example pl or fr - list is here1
Change date format to - YYYY-MM-dd HH:mm:ss
tick the ‘Show international dates?’ checkbox

Now on the forecast item, set it to ‘5 days…’ view option, tick ‘override template’ and then find:

<div class="weekday">[time|l]</div>
<div class="weekday-short">[time|D]</div>

Change it to:

<div class="weekday">[time|cccc]</div> 
<div class="weekday-short">[time|eee]</div>

I have done all of it, but now I get this:

The instructions where correct - but I guess you do not have international date support enabled on your PHP installation. You can verify this on the Report Fault page in the CMS which will show you whether that extension is enabled or not.

So I have to update it like this How do I enable Intl in PHP?

Yes, exactly so.

1.8 solves this problem completely - I appreciate that doesn’t help you right now, but may be useful for anyone that happens across this topic in the future.

1 Like

Thanks, I have installed the PHP extension and now it works.

1 Like