Fetch Remote Dataset not working, no data come in datasets

Hi all,
I’m facing an issue on my new instance 3.1.3 docker installation on Ubuntu 18.04. I’ve export from another cms (3.1.1) layouts with datatsets and import them in my new instance.
When I tried to fetch remote dataset, no datas was coming in my datasets.

I thought that it was an issue with my layouts freshly imported but I try to create a new remote dataset with json link and no synch was able for this one to…




image

The URL : https://api.rss2json.com/v1/api.json?rss_url=https%3A%2F%2Fla1ere.francetvinfo.fr%2Fnouvellecaledonie%2Fgoogle-actus.rss&api_key=g69aqxt8ususii3rxriz4iq2muhmpozmkvlccko6

Thank’s in advance for your help.

Best regards,

I’ve created a debug task and I found this in logs :
31117,dd9c40e,“2022-06-28 18:47:00”,CONSOLE,GET,“Running Task Fetch Remote DataSets [6], Class = \Xibo\XTR\RemoteDataSetFetchTask”,DEBUG
31118,dd9c40e,“2022-06-28 18:47:00”,CONSOLE,GET,“Checking permissions against the logged in user: ID: 1, Name: cms_admin, UserType: 1”,DEBUG
31119,dd9c40e,“2022-06-28 18:47:00”,CONSOLE,GET,"Order of processing: [&quot
31120,dd9c40e,“2022-06-28 18:47:00”,CONSOLE,GET,“Processing test. ID:7”,DEBUG
31121,dd9c40e,“2022-06-28 18:47:00”,CONSOLE,GET,“Skipping dataSet 7 due to it not being accessed recently”,INFO
31122,dd9c40e,“2022-06-28 18:47:00”,CONSOLE,GET,“Processing NEOTECH 2. ID:5”,DEBUG
31123,dd9c40e,“2022-06-28 18:47:00”,CONSOLE,GET,“Skipping dataSet 5 due to it not being accessed recently”,INFO
31124,dd9c40e,“2022-06-28 18:47:00”,CONSOLE,GET,“Processing NEOTECH. ID:2”,DEBUG
31125,dd9c40e,“2022-06-28 18:47:00”,CONSOLE,GET,“Skipping dataSet 2 due to it not being accessed recently”,INFO
31126,dd9c40e,“2022-06-28 18:47:00”,CONSOLE,GET,“Processing NC1ERE_GOOD. ID:6”,DEBUG
31127,dd9c40e,“2022-06-28 18:47:00”,CONSOLE,GET,“Skipping dataSet 6 due to it not being accessed recently”,INFO
31128,dd9c40e,“2022-06-28 18:47:00”,CONSOLE,GET,“Processing NC1ERE-BIS 2. ID:4”,DEBUG
31129,dd9c40e,“2022-06-28 18:47:00”,CONSOLE,GET,“Skipping dataSet 4 due to it not being accessed recently”,INFO
31130,dd9c40e,“2022-06-28 18:47:00”,CONSOLE,GET,“Processing NC1ERE-BIS. ID:1”,DEBUG
31131,dd9c40e,“2022-06-28 18:47:00”,CONSOLE,GET,“Skipping dataSet 1 due to it not being accessed recently”,INFO
31132,dd9c40e,“2022-06-28 18:47:00”,CONSOLE,GET,“Finished Task Fetch Remote DataSets [6] Run Dt: 2022-06-28 18:47:00”,DEBUG

“Skipping dataSet 1 due to it not being accessed recently” What does it mean exactly ?
best regards

The dataset must be being actively consumed by a Player for it to be updated otherwise the CMS won’t do so.

Hi Alex,
Thank you for your answer.
In fact, I’m not sure to understand “actively consumed”… Do you mean a player playing a layout with datas requested from a dataset ?
I have actualy 9 players with datasets requests since 3 days. I 've cleared the cache of each players to see if it change something but the datasets still empty.

On the player the layout play “NO DATA RETURN FROM THE SOURCE”.

Maybe I missed something ?

Actively consumed means that the Players are connecting to the CMS and showing layouts that use those datasets.

If they are doing that, then the dataset will be marked as in use and will be refreshed next time the Remote Datasets task runs.

Hi Alex,

Thank you for this explanation. I can see now how it work.

Actualy I have 10 players with layouts include Remote datasets. I let them playing one entire day but unfortunatly the datasets still not synchronised. I presume the dataset is not marked as “in use” . Could we manualy mark the dataset as “in use” by default all the time ?

If we couldn’t what do you suggest to force the remote dataset synch ?

Best regards,

After changing the task scheduling period, The dataset sync well :slight_smile:

Thank you Alex for your help.

Best regards,