"Fatal Error" upon installation

CMS Version

2.1

Installation Method

Docker

Operating System

Windows 10

Issue

Everything appears to have installed correctly, but after the service should be running, I visit the appropriate url (I have a custom port set in the correct yml file) and rather than any interface, I get the following error:

Fatal Error - sorry this shouldn't happen. SQLSTATE[HY000] [1045] Access denied for user 'cms'@'172.18.0.5' (using password: NO)

Looks like a sql connection problem, but I didn’t touch any settings relating to the database. Any thoughts on how to resolve this?

Okay, so I am actually using xibo version 2.3.6.

Everything appears to be running, but I’m still getting the same error when I try to access the running installation. I can’t get the db to connect.

I tried docker desktop’s launch a command line thing, but not knowing the username/password that is set in mysql’s user table, I can’t directly access the mysql db to make sure the “cms” user has correct permissions. None of the defaults I tried were working.

But shouldn’t this already be set correctly in the docker file?

I’d really love to get this up and running. My boss would like play with it before we settle on a digital signage platform to use at our properties.

The Xibo Community site uses cookies. What are cookies?