Failed to create cache path if using Xibo-cms with docker on Windows

image

Background:
I had tried xibo-docker from Github and it works fine on both Windows and Linux.
I had tried xibo-cms from Github and it works fine only on Linux but not on Windows.
I want to extend the xibo-cms so I cloned from xibo-cms repo to get the source code. I followed the instruction written on Readme.md to run the project but it’s only for Linux. (I only have Windows PC for software development.)

Issues:
I got the error like in the image “Failed to create cache path”. Only happens on Windows. (Linux runs fine as I tested on DigitalOcean Ubuntu cloud)

Environment:
OS: Windows 11
Repo cloned: GitHub - xibosignage/xibo-cms at master
Version: Xibo 4.0.11
Running with the included docker compose.

Steps to reproduce:

  1. On Windows, clone from this: GitHub - xibosignage/xibo-cms at master
  2. Follow Readme.md
  3. Install dependencies for PHP and NPM both by “docker run” option using Windows Powershell. (Some paths are modified away from the instruction in Readme.md since Windows cli has different path syntax)
  4. edit permission. mkdir cache; chmod 777 cache; chmod 777 library
  5. edit docker-compose.yml to use Dockerfile.ci so it runs migrate DB.
  6. run docker compose up --build -d
  7. go to http://localhost and then got error like in the image.

The steps above is fine only on Linux but I have only Windows PC atm.
Happy to see solutions or suggestions to try.
Best regards;