Error "must be a mapping and not a string" in installation. Plus fix

CMS Version

2.1

Installation Method

Docker

Operating System

Windows 10

Issue

While following the instructions for the docker install, I use a custom cms_custom-ports.yml file so I can change the port it uses to listen. When I run

docker-compose -f cms_custom-ports.yml up -d

I get

ERROR: In file '.\cms_remote-mysql.yml', service ':version' must be a mapping not a string.

I went crazy looking over and over at the cms_custom-ports.yml file to see what the problem was until I finally realized the error was with default-provided cms_remote-mysql.yml file. In that file, on line 1, there is an errant “:” before “version”. I deleted it, then tried again, and now everything seems to be installing fine.

But you guys might want to fix that file in the download.

Also a note on Docker Windows 10 installation instructions. In the latest version of Docker, the “Shared Drives” top menu item is gone, but the functionality is now under Resources > File Sharing.

Welcome to the Community.
Could you point us to the file you downloaded that has that in it so we can take a look and get that fixed. We have looked in each release file for 2.1.x and as yet have not located the extra colon.

Thank you

This page https://xibo.org.uk/cms the big download button links to https://xibo.org.uk/api/downloads/cms which forces a download of xibo-docker.zip. Inside the zip there is a directory labeled xibo-docker-2.3.6, in there is cms_remote-mysql.yml, the first line of which reads

:version: "2.1"

Which I may have been wrong at the version number of xibo I’m using. That directory says 2.3.6, but all the yml files say 2.1.

Thank you for passing those on. The version line at the top of the yml files is the version of the docker-compose syntax used and not the version of the CMS, and so we have been looking in the wrong place to find this. We do see it now and will get that fixed. Thank you for bringing that to our attention :slight_smile:

The Xibo Community site uses cookies. What are cookies?