Error message when I click on "Library" on web page

Hello,

We have a xibo in version 1.7 running on a virtual machine at a service provider. We need to upgrade it to the latest version 2.3.10. So I contacted the provider who provided me with a second virtual machine to update Xibo (and our redmine ticket software too) on Debian 9.

The provider took care of the installation, so I upgraded to version 1.8.8, then to version 2.3.10. I migrated the database, where I can see the users, the displays for example on the xibo in version 2.3.10. However when I click on the “Media” menu on the web page, I get the following error message:

My url does not contain /web as I have seen on some forums, the url for the media menu is: https://xibo.[domain]/library/view

I wondered if there was an access problem on the library folder, so I set the rights to 775 but it doesn’t change anything.

the architecture of the Xibo file is like this:

Xibo folder:

Web folder:

I tried a lot of things found on the community forum but I’m not sure… I tried to modify the .htaccess file to put an url rewriting but I had lost access to the web page.

Do you know where the problem can come from?

Thank you in advance.

screen_xibo_forum(2)

screen_xibo_forum(3)

I have now this error message:

DataTables warning: table id=libraryItems - Invalid JSON response. For more information about this error, please see http://datatables.net/tn/1

And I have this message in console web page:

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.