Hi all ! hope you’re doing well an safe
this is my first topic :slight_smile:
I’m trying to install the CMS, first, I tried on mutual hosting, I was able to display the first page with the requirement but when I clicked on NEXT I had the error message: ERR_TOO_MANY_REDIRECTS
in the link I have this URL :

I was thinking thas related to the hoster, so I tried in my computer using Wamp Server wampserver3.2.3_x64

Any idea about this issue ?
Thank you !

CMS Version


Installation Method


Operating System

win 10 64



1 Like

I’m having the same issue, cms 2.3.8, any help?

Here the same issue.

I have experienced the same problem, in my case it was the HTTPS redirection. Please disable this where you have made the custom changes. In my case it was in the /etc/apache2/sites-available/xibo-cms.conf

Depends where you made the changes, could also be in .htaccess

Seems like install page does not like https…

I think your write, but when I check the .htaccess I don’t see difference;

RewriteEngine On

#RewriteBase /xibo

# fix authorization header
RewriteCond %{HTTP:Authorization} .+
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

# requests for api authorize
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_URI} ^/api/authorize/.*$
RewriteRule ^ api/authorize/index.php [QSA,L]

# requests that start with api go down to api/index.php
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_URI} ^/api/.*$
RewriteRule ^ api/index.php [QSA,L]

# install
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_URI} ^/install/.*$
RewriteRule ^ install/index.php [QSA,L]

# maintenance
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_URI} ^/maint/.*$
RewriteRule ^ maint/index.php [QSA,L]

# all others - i.e. web
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !\.(css|js|png|jpg)$
RewriteCond %{REQUEST_URI} !^/dist/.*$
RewriteCond %{REQUEST_URI} !^/theme/.*$
RewriteRule ^ index.php [QSA,L]

I have the same problem with the versions:

  • 2.3.6
  • 2.3.7
  • 2.3.8
    But it works fine with the version 2.3.5

WampServer ( php 7.2.34 ) - Windows 2019 server

Thank you !


I have the same problem. I am using the Hostgator provider platform to install Xibo CMS 2.3.8

I didn’t find anything in the files: .htaccess and index.php
I don’t have the xibo-cms.conf file in my structure

Note: I have on the same platform a web application running Xibo CMS 2.0.4 and everything is OK.

any help?

I have now ran into this as well. Will the Xibo troubles ever end?!

Turns out that the web.config rules IIS generated from importing the .htaccess file did not match what is described here:

Once I corrected them to match the above link, it worked!

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.