Enabling two factor authentication doesn't show QRCode

Hello team !

When I try to enable TFA with Google Authenticator, an error occurs when generating the QRCode image :

If I try to open the image, Firefox tells me it can’t open because it contains errors :

Google Chrome behaves the same.

I have a Docker install with V3.3.0

Thank you for your help.

Hi, can I ask if your setup is on a local network only?

If you do have internet connection for your CMS could I ask that you collect some fault report logs while you load the 2FA menu and a QR code is attempted? Hopefully the logs will explain why that is failing and not being generated for you.

Many thanks

Hi Dagonix,

I have the same issue for several months and I tried many modifications but without success. Did you find a solution ?

Thanks you

Could you confirm if you are both using something other than a Docker install?

Many thanks

Hello Natasha,
I’m using a Docker install on a virtual machine.

My setup for the new install :
A Proxmox VE hypervisor v7.3.4
An Ubuntu 22.04.1 VM (8Gb ram / 4 vCPU / 500 Gb HDD) for Xibo
Docker 20.10.22, build 3a2c30b
Docker-compose 1.29.2

I couldn’t resolve the QR code issue with a clean install. Tried changing the versions of docker/docker-compose, tried changing the specs of the vm but nothing helps.

I kind of “solved” my problem by taking an old vm of Xibo 2.3.14 and did the necessary upgrades of the system and Xibo.
Doing the upgrades, the QR code shows well but not with a new install. So it is not an environment problem when running but an install problem.

I suspect (but not sure) that it might be related to a proxy configuration within the QR code generator module.

Even though my system can access the internet through a well configured proxy (docker pulls the images seemlessly and the Xibo newsfeed show well and the server can reach internet RSS feeds), maybe at install time the QR code module needs to access the internet and it doesn’t know how to use the proxy.
That’s what I guess, I’m not sure about it.

Maybe magicpower can tell more to help diagnose ?

Hi magicpower,
I answered Natasha down here.
Can you help diagnose by telling more about your setup ?

Hi thank you for providing further information.

We have attempted to reproduce this issue in Docker but it seemingly works in every scenario we have tried. We have however identified a possible issue with non-docker and have included a fix in our upcoming 3.3.3 release which is due next week.

We would therefore suggest trying the fix in 3.3.3 next week to see if that fixes things for you. You could also check the value of the QUICK_CHART_URL setting in the database.

Please do let us know the outcome.

Thank you for your suggestion Natasha.

I have a Docker install but I’ll test the 3.3.3 next week to see if something changes.
For the QUICK_CHART_URL setting, I use the container provided with Xibo, so I didn’t set the URL.

I’ve done some testing on 3.3.2 and not been able to reproduce this at all.

Please can you tell me what value you have for QUICK_CHART_URL on the CMS that works and on the one that doesn’t please? You may not have set it directly, but it must have a value. You may not be able to see it in the CMS UI so will need to look in the database directly.

Please can you also tell me what value you’ve set for Two Factor Issuer.

Hello Alex,

Both the working and the not working CMSes have this value value in the setting table :

121 | QUICK_CHART_URL | http://cms-quickchart:3400

Also, they both have the same issuer : CampiX CMS

Thank you for your help.

The one that doesn’t work is an error message from your proxy server.

You probably just need to add cms-quickchart to your proxy exceptions in the main CMS configuration - since you’re talking to a local container that doesn’t need to go via your proxy server.

Yes Alex, you’re right! It is a proxy problem indeed.
Now I cannot say why, in the global settings, both servers have the same settings but they don’t react the same way.
The legacy server, upgraded to Xibo 3.3.2 generates the QR Code, the new server, installed from scratch, doesn’t.
I tried to add cms-quickchart to the exceptions, I even tried to disable the proxy, but none ot these made it work. I also tried to add the IP adress of the container but without success. It’s like if the exception list is not taken into account.

Settings are cached in the CMS so you may need to fully refresh the page between changing a setting and then trying to generate a QR code.

Otherwise I’m not sure why it wouldn’t be working if the other does work. I can only think it’s something in the environment that differs between them. Without detailed knowledge of your setup it’s nearly impossible for me to guess.

You could instead change the QUICK_CHART_URL field to use https://quickchart.io instead, but it’s marginally less secure since a third party service is then rendering that QR code for you.

Thank you Alex for your time.

I checked the environment to see what differs but can’t see any difference for now. I will double check again when my vision will clear but changing the Quickchart URL did the trick for now :
UPDATE setting SET value='https://quickchart.io' WHERE settingID='121';

The QR Code is generated!

Big thanks :+1:

You’re welcome. For others reading this later, settingID will be specific to this database, so target your query like

UPDATE setting SET value='https://quickchart.io' WHERE setting='QUICK_CHART_URL';

Hi Dagonix,

Sorry for my late answer !

My setup for the new install :
A Dedicated server
An Ubuntu 18.04.6 for host
Docker 20.10.22, build 3a2c30b
Docker-compose 1.24.0 build 0aa59064

Xibo CMS V3.3.2 installed with docker container

I solved my issue because i see your post and my QUICK_CHART_URL is http://cms-quickchart:3400 but my docker container quichart was named differently

I renamed my container and the QR Code generated !

Thanks for your help ! :+1:

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.