DSCS9 3-R303 not setting time from CMS

Taken delivery of 10 odd DSCS9 devices - have upgraded to Player 3 R303 but they are still not setting their device time from CMS. Any suggestions?

Connecting over HTTP as advised.

Does your CMS automatically redirect /clock to HTTPS at all?

eg http://cms.example.org/clock should remain HTTP, but https://cms.example.com/login should redirect to HTTPS.

If it does then they won’t be able to set their time using the CMS as an HTTPS connection requires the correct date and time.

The correct setup is for your webserver or reverse proxy not to redirect to HTTPS, and instead have Xibo do that for the URLs that it needs it for.

Discovered our Unbuntu server Firewall was preventing port 80. So we now got http connections working but still no CMS time sync. Have a ticket with the XIBO Android helpdesk open (#036080) and they are suggesting to tick the “Set approx date/time on start” option within the Android XIBO App

You can try that, but it will only work once the Player has been running for a time, and the Player won’t be able to correct the time fully. It’s only there for devices where no network access is possible until a secure connection can be made.

For the Player to set the time from the CMS, I believe it only does it at startup, so I’d ensure you don’t have a redirect as I setout above - if you do, it can’t work.

Assuming you don’t have an https redirect there, then ensure you have the option to set the time from the CMS set and that the Players have connected to the CMS once to pickup that change (you’d have to manually set the time for that to be possible), and then they should do that going forward.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.