Displays won't display updated layouts

I am not sure what category to put this is. I am having a problem I just can’t seem to resolve. I have 4 displays, all Windows 10 Pro boxes running the latest Windows Player R301 and I am running Xibo 3.0.2 on Windows Server 2012R2 (not docker) IIS 8.5, MySQL 5.7. It all works very well, until I try to update a layout that I is currently scheduled and playing on the displays. I check out the layout, make my edits (usually it involves adding or deleting some images), and then Publish the layout. What will then usually happen is that 2 of my 4 displays will update normally and begin playing the updated layout, but 2 of them will invariable revert to playing the Default layout. It’s never the same displays, it’s always a random combination. Restarting the player on the displays does nothing, deleting and recreating the schedule does nothing, the only way to “solve” it is to go into Displays in Xibo, Edit each of the malfunctioning displays, go to Advanced, and check “Clear Cached Data” and then save. After doing that, the display will then pickup the new layout.

The following errors are logged when this happens (in order first to last):

SQLSTATE[40001]: Serialization failure: 1213 Deadlock found when trying to get lock; try restarting transaction

Not found FileId: 60. FileType: layout. Required file not found for Display and Layout Combination
Unable to find file in media inventory: layout. 60

Exception in Run: Client found response content type of ‘text/plain;charset=UTF-8’, but expected ‘text/xml’.The request failed with the error message:–There has been an unknown error with XMDS, it has been logged. Please contact your administrator.–.

Exception in Run: Requested an invalid file.

I am unsure what else to do or how to troubleshoot further at this point. Any help would be greatly appreciated.

Anyone got any ideas? I’ve updated to 3.0.3. and still same behavior.

The Xibo Community site uses cookies. What are cookies?