Didn't show some data Twitter API

[ProfileImage] and [Photo] don’t show anything but [User], [Date] and [Tweet] is work fine. What I mistake in this situation.

Result picture (search for funkyvilla)

Original content from twitter

Thank you for advance your time.

Edit. I use cms 1.7.5 and can I use facebook website by webpage feature?

That does not seem to belong in features category, I moved it for you.

So if you use template ‘Full twitter time line’ it should show everything correctly (it does for us)
Make sure that everything is correct, according to http://xibo.org.uk/manual-tempel/en/media_module_twitter.html and this Using Tickers, Forecast, Twitter and other external resources that make use of HTTPS connections

Are there any erros in CMS logs? (you might need to enable debugging on Report fault page to see logs)

Update to 1.7.6 would be recommended too.

As for facebook, it’s not directly integrated with Xibo, you could use https://developers.facebook.com/docs/plugins/embedded-posts
and embedded html module to display it in Xibo.

Thank you sir I’ll try it. if I got problem I’ll ask again. :grin:

I try to use 1.7.6 with template ‘Full twitter time line’ already but I got same problem.

Here log from CMS

I think this problem didn’t show picture only. Do you have some suggestion?

logs seems to look quite good, I can’t see whole logged message, but I assume that in getTwitterFeed there are URLs to images (in this tweet and other images on this profile).

And there are no errors regarding twitter api? or ssl anything like that?

You might want to also try different browser / clear the browser cache to make sure that’s not the cache issue.

This is log of getTwitterFeed Dropbox - getTwitterFeed.txt - Simplify your life.
I try to test in firefox and clear browser cache already but photo still don’t show.

I verify all after and see the log. Still don’t see error about “SSL certificate problem, verify that the CA cert is OK” or “Unable to reach Forecast API. No Host Found (HTTP Code 0). Curl Error = SSL certificate problem: unable to get local issuer certificate”.

Thank you sir.

Here is new log file after I insert twitter api in region

Hello Dan
I think Nesu is resolve his problem already but my problem is [profilephoto] didn’t show picture. :sob:

Oh dear! :confounded:

Well, there are a few reasons why that might be the case - an extract of your error log will be interesting here. Do they show in the CMS or Player or neither?

Hello Dan
Photoprofile didn’t show both of CMS and player. It’s only show circle that don’t have picture.
Thank you very much for help. :laughing:

I understand now - you had an old topic with your problem in it so I have moved the old posts over.

I’ve read through the topic and all the logs you have posted so far seem to be OK. That means we are going to need new logs :confused:

Can you please do the following:

  • Create an empty layout
  • Create an empty region
  • Open the Twitter Form and fill it in
  • before you press save, open a new tab
  • in the new tab go to “report fault” and turn ON debugging
  • in the new tab go to “log” and click “truncate” to empty the log
  • Switch back to the original tab and press save
  • in the new tab go to the fault page and collect log
  • post the troubleshoot.txt file in dropbox and we will look


Here’s link https://www.dropbox.com/s/44batpna3po9m1c/troubleshoot.txt?dl=0

Thank you in advance

You’ve hit a different problem now:

  "errors": [
      "message":"Unable to verify your credentials",

This is before the tweets are even downloaded - so way before any :camera: are downloaded.

Can you double check your oAuth key and secret in the Module Administration page?

Sorry for my mistake Dan.
Here’s new log after add correct oAuth key and secret key https://www.dropbox.com/s/ua04f27vwwz7yji/troubleshoot%20(1).txt?dl=0
Thank you in advance.

Sorry, I don’t see it from the log… any way we have have remote access?

Yeah. I’m convenient to let you remote to my computer when you have free time.
Thank you for help. :smile: