Dataset in ticker, show one item at a time

Hi there,
New on Xibo and I really like the features.

I ran into a problem. I followed This tutorial for a slightly diffrent purpose but I didn’t work. In the settings of the thicker I should choose: direction: single, to be able to show only one item at a time. I can’t find this option, guess it didn’t return in the newer version. Under ‘Format’ I find an alternetive: Articles/Items per page. Setting it to 1, 2, 3, 5 or whatever: It doens’t make any changes. Al the item’s are shown.

How can I fix this?

Xibo 1.7.4


I’ll try to explain it.

Let’s say you created everything like in this tutorial then you would have only 1 item at any given time, so obviously with filter NOW() > dtMeetingStart AND NOW() < dtMeetingFinish it would display only one item.

If you added more (or didn’t use this filter) then by default it will display every item you have in your dataset.

You can use filter to narrow it down to specific item(s) and if you have more than 1 item to display at some date then what you want to do is:

set effect (one that you like, doesn’t matter which one)
set items per page to 1 (assuming you want to display only 1 item)

tick the checkbox 'Duration per item" in advanced (optional but I would suggest it)
set duration to something more reasonable (since now it is duration per item)

I hope this will help you set it up and understand how it works, if you’d have any other questions please let us know

Sometimes it that simple :wink:

Worked perfectly! Thanks!

1 Like